[luatex] Downloaded compiled version of luatex 0.75 for MacOSX, am getting error related to luatex-loader.sty and oberdiek.luatex.lua

Mico Loretan mico.loretan at mac.com
Sat Mar 23 17:45:11 CET 2013


This is a follow-up to my earlier posting (about obtaining a compiled copy of LuaTeX for MacOSX, either 0.74 0 0.75). I've "found" a copy of version 0.75 in the meantime, at http://minimals.contextgarden.net/current/bin/luatex/osx-intel/bin/.

I run MacTeX2012, and I saved the current version of luatex (0.71) before moving the new executable to its expected location, viz., /usr/local/texlive/2012/bin/x86_64-darwin. I then rebuilt all format files, per the installation instructions, using the commands "sudo fmtutil --all" and "sudo fmtutil-sys --all". (Aside: using either method, I got warning messages that the builds of the following formats failed: amstex, eplain, eptex, and euptex. Since I don't use these formats, I'm not concerned about them...)

I then tried to compile a program that executes the instruction 

      \directlua{  require("selnolig.lua")  }

where selnolig.lua, unsurprisingly, contains some lua code. Unfortunately, the program crashes at that point, with the following error message:

! LuaTeX error ...ive/2012/texmf-dist/scripts/oberdiek/oberdiek.luatex.lua:55: 
bad argument #1 to 'insert' (table expected, got nil)
stack traceback:
	[C]: in function 'insert'
	...ive/2012/texmf-dist/scripts/oberdiek/oberdiek.luatex.lua:55: in main chunk
	[C]: in function 'dofile'
	[string "\directlua "]:6: in main chunk.
l.139   }

Something isn't quite right in luatex-loader.sty, right?

Just for completeness, I downloaded the entire source code for luatex 0.75 and compiled it on my system. (I have Xcode 4.6 plus the command line tools for Xcode, for MacOSX "Lion".) I was able to compile the thing without crashing. Sadly, after setting the proper file permissions, installing it to /usr/local/texlive/2012/bin/x86_64-darwin, and re-running fmtutil and fmtutil-sys, I get the exact same problem as reported above when I try to compile my tex file.

Are there other files besides the executable that must be updated and/or reinstalled before I can run luatex 0.75 on MacTeX2012? Please advise.



More information about the luatex mailing list