[luatex] luaotfload problems (MiKTeX/Windows 7) | not solved

Evan Cooch evan.cooch at gmail.com
Sat Jul 6 19:35:53 CEST 2013

> That line has been there since this commit:
>      https://github.com/lualatex/luaotfload/commit/00fd07c628af41b0709d25fd00805385be561459#L3R202
> and is definitely part of the v2.3 zip. Something’s off with your
> install. You can check whether you’re running the correct version
> with luaotfload-tool --version.

mkluatexfontdb 2.3
database version 2.207

>> In fact other than the statements about where the font database will
>> be written to, runing luaotfload-tool --help shows me nothing else.
>> At all.
> It should print 59 lines of usage info.

I tried again. It doesn't. Only the 2 lines I reported earlier.

> If I remember correctly, Windows distributions use binary
> wrappers for Lua scripts. Maybe the one for luaotfload-tool.lua
> points to an old version of the file?
Alas, only one version on the machine.

About all I can do at this point is try a full re-install, and see what 
happens. I can install as a user (i.e., install 'just for me'), or as 
admin (i.e, 'install for everyone').

While this doesn't take heroically long, it takes longer than I have 
time for today.

What you/we need is someone else with a MiklTeX install under Windows 7 
(Pro, if that matters), to see if they're having the same problem.

More information about the luatex mailing list