[luatex] updates to various lua* packages breaks..something.

Evan Cooch evan.cooch at gmail.com
Wed Apr 24 12:58:27 CEST 2013


On 4/24/2013 4:49 AM, Philipp Gesang wrote:
> Hi Evan!
> ···<date: 2013-04-23, Tuesday>···<from: Evan Cooch>···
>> First time posting to this list. Apologies if posts 'like this'
>> should go somewhere (or to someone) else.
>> After most recent (23 Apr) updates (I'm using MikTeX 2.9) to various
> Which most recent update are you talking about? Could you please
> add the output of mkluatexfontdb -V ?

mkluatexfontdb version 1.07, database version 2.009

This is the *current* version I 'updated' too. Whatever the previous 
version was generated no errors.

> How do you use luaotfload? Plain or Latex? With fontspec? Could
> you please post a minimal example that triggers the error with
> fonts that are on CTAN? Thank you.

With fonts that are on CTAN? That sort of defeats the purpose of using 
fontspec in the first place! :-)

But, it doesn't matter. I normally use Minion Pro (which I own), but it 
fails even using XITS  Here is a simple MWE


   \setmathfont{Asana Math}


Lorem ipsum dolor sit amet, consectetur adipiscing elit. Praesent in 
tincidunt nulla. Donec quis laoreet est. Aenean vitae est felis, a 
venenatis magna. Mauris semper bibendum vulputate. Etiam bibendum quam 
ut erat rutrum consequat.


Lorem ipsum dolor sit amet, consectetur adipiscing elit. Morbi eget 
dolor ac diam interdum volutpat. Cras luctus congue nibh, at dictum 
nulla iaculis quis.


When I try to compile this using lualatex (using MikTeX 2.9),  it 
absolutely refuses to compile. For this MWE, the error message actually 
occurs during liaotfload:

Luaotfload | scanning TEXMF and OS fonts...lualatex: Unexpected condition.

And then it stops.

>> Compilation itself does seem to progress 'correctly', but something
>> that takes twice as long (because of what appears to be a bug
>> causing luaotfload to run every time a file is compiled, is not an
>> 'update'.
> Probably an incorrect "file:" lookup.


>> Wonder if its related to the following. If I bring up an admin cmd
>> console, and run
>> mkluatexfontdb -f -vvv
>> I get an error:
>> mklualatexdb: Windows API Error 5: Access is denied
>> mklualatexdb: Data: C://Documents and settings
> Sorry, no idea. Maybe you need to pass it to texlua?

Sorry, but that seems like a stretch.  Everything worked before worked 

>> When I run this on my other machines - which I have not 'updated' -
>> mkluatexfontdb runs fine.
> Again, which version?

See above.

>> Suggestions? Clearly something has been 'broken' during the update -
>> at least on Windows machines running MikTeX 2.9.
>> Thanks in advance.
> Thanks for reporting
> Philipp

Sure -- not sure what else to report.

I think the fact that mkluatexfontdb doesn't run - at all really - is 
telling. Could it be a corruption of something on this one - updated - 
system? Suggestions on what to look for?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/luatex/attachments/20130424/130b1e02/attachment.html>

More information about the luatex mailing list