[luatex] configure error on mingw

Peter Rolf indiego at gmx.net
Wed Mar 17 13:45:09 CET 2010

Am 17.03.2010 12:45, schrieb T T:
> On 17 March 2010 09:55, Peter Rolf <indiego at gmx.net> wrote:
>> Am 17.03.2010 00:29, schrieb T T:
>>> On 16 March 2010 23:08, Peter Rolf <indiego at gmx.net> wrote:
>>>>> same little hiccups here. just run a single 'make' without additional
>>>>> arguments and you should get a clean luatex binary.
>>>> oeps, i meant './build.sh'
>>> Nope, it doesn't work unless I patch in the --without-ln-s. I tried
>>> './build.sh' twice in a row to make sure. It failed the same way both
>>> times.
>> mh, i got a working version here after a single './build.sh'.
>> this is the content of my 'installed.ini' in the mingw directory. OS is
>> vista64. do you see any differences?
> I hand crafted my MSYS install (by unpacking various *.tar.gz files)
> and don't remember any more which versions I have atm. I will try to
> update it and see if it helps.
mingw now comes with a simple installer. just download 'MinGW-5.1.6.exe'
and start it. then select the packages to install (see my
'installed.ini' file).

[mingw-installer on top]

i still use msys 1.0.11 here. a newer version can be found in the file
section of the upper link (but looks like sources only).
anyhow, installation should be no problem for you.

best wishes


>>> PS. Unrelated question: is it possible to build with --enable-shared on mingw?
>> i donno. but knowing that option makes you an 'expert', so give it a try ;)
> I tried and:
> configure: error: you can not use a shared Kpathsea library for a
> native TeX Live build
> ??
> Cheers,
> Tomek

More information about the luatex mailing list