[luatex] configure error on mingw

T T t34www at googlemail.com
Wed Mar 17 12:45:16 CET 2010

On 17 March 2010 09:55, Peter Rolf <indiego at gmx.net> wrote:
> Am 17.03.2010 00:29, schrieb T T:
>> On 16 March 2010 23:08, Peter Rolf <indiego at gmx.net> wrote:
>>>> same little hiccups here. just run a single 'make' without additional
>>>> arguments and you should get a clean luatex binary.
>>> oeps, i meant './build.sh'
>> Nope, it doesn't work unless I patch in the --without-ln-s. I tried
>> './build.sh' twice in a row to make sure. It failed the same way both
>> times.
> mh, i got a working version here after a single './build.sh'.
> this is the content of my 'installed.ini' in the mingw directory. OS is
> vista64. do you see any differences?

I hand crafted my MSYS install (by unpacking various *.tar.gz files)
and don't remember any more which versions I have atm. I will try to
update it and see if it helps.

>> PS. Unrelated question: is it possible to build with --enable-shared on mingw?
> i donno. but knowing that option makes you an 'expert', so give it a try ;)

I tried and:

configure: error: you can not use a shared Kpathsea library for a
native TeX Live build




More information about the luatex mailing list