[lltx] [fontspec] selecting font features has no effect?

Diederick C. Niehorster dcnieho at gmail.com
Tue Mar 30 07:47:32 CEST 2010

Hi All, Khaled,

This is fontspec related, so I'll keep it on this list, per suggestion
before ;)

I am having trouble with ligatures not showing up, nor other font
features, tried swashed italics (I tested using the same fontspec on
XeLaTeX, and it works fine). See minimal example below (you might also
want to note that again I managed to burn 800MB compiling it).

Khaled, you might recognize that ligature test from your luaotfload
tests, when I run luatex on those they work fine.

Also, a feature request: when a \fontspec related command is given an
option it does not recognize, could it write a warning? I was messing
with 'Rawfeature' for a while, only later figuring out it should be
'RawFeature'. Warnings would have helped and are useful in general
when input is not what it should be.


%\setmainfont[Mapping=tex-text,Ligatures=Common]{TeX Gyre Heros}
\setmainfont[Mapping=tex-text,Ligatures=Common]{Arno Pro}

``fi fl ffi--ffl---ff!`''\par



To unsubscribe from this group, send email to lualatex-dev+unsubscribegooglegroups.com or reply to this email with the words "REMOVE ME" as the subject.

More information about the lualatex-dev mailing list