[l2h] Some mathematical images in my case not fully processed by LaTeX2HTML 1.71 using both an old and a new .tex file

Pat Somerville l_pat_s at hotmail.com
Thu Jul 11 07:12:39 CEST 2013

Hello.  I checked the dates of "builds" of software packages that I have installed and with names of software packages that LaTeX2HTML requires and found that a number of them were "built" before I installed a working pair of LaTeX and LaTeX2HTML computer programs in an openSUSE-12.3 Linux operating system by about March 20, 2013. For example, for the software packages Netpbm and Perl, which LaTeX2HTML requires, the dates of the "builds" of them that I now have installed in my Linux operating system are earlier in time than the date of my installations of openSUSE-12.3 Linux, LaTeX, and LaTeX2HTML which gratefully worked well together in late March of the year 2013. But yet something apparently changed in the software installed in my openSUSE-12.3, Linux operating system between late March of the year 2013 and early July of the same year to cause a problem for LaTeX2HTML 1.71. 

Today I provide additional information which may or may not provide clues to why "Image" instead of "1/2" appeared in equation mode in the .html (HyperText Markup Language) equivalent produced by LaTeX2HTML 1.71 of the LaTeX code y=\frac{1}{2}x^2. For discussion purposes here I use the fictitious file name MyFile.tex; my actual file name is different from MyFile.tex. As a non-root user after executing a command of the form "latex MyFile.tex" and then a command of the form "latex2html ......... MyFile.tex," I saw in the output

"Images will be generated in /tmp/l2h1683

Error: Unlink "WARNINGS" failed: Permission denied at /usr/bin/latex2html line 9269. Cannot create directory 'TMP': Permission denied


And afterwards I did not find the subdirectory l2h1683 in the /tmp directory.

Executing the command of the form "latex2html ........ MyFile.tex" as a root user I think eliminated such error messages. But unfortunately still the desired "1/2" did not appear in the output, .html file in equation mode.

I unstalled the openSUSE-12.3 software package called "latex2html" and reinstalled it using Yet another Software Tool 2 (YaST2). Things worsened.---After a command of the form "latex MyFile.tex" the file html.sty was reported as not found. But html.sty was in the directory /usr/lib/texmf/tex/latex/html. So please explain how I can make LaTeX2HTML "find" it there. Anyhow, copying html.sty from /usr/lib/texmf/tex/latex/html to my directory in which I store .tex files and running a command of the form "latex MyFile.tex" there was what one might call a "workaround" solution that enabled "LaTeX2HTML" to "locate" a copy of the file html.sty. After executing a command of the form "latex2html ...... MyFile.tex," the desired "1/2" in equation mode still did not appear in the produced file with a name of the form MyFile.html. Inserting ? in each of two lines of code in the file /usr/bin/latex2html according to http://tug.org/mailman/htdig/latex2html/2008-December/003489.html eliminated mathend# appearing in place of mathematics in text of the .html output file.

I experimented and found that as a non-root user in the Konqueror Web browser and file manager I could make a test subdirectory and delete it. As a root user I entered the command "lsattr -d /tmp" and obtained a result similar to "----------e-- /tmp" with the "e" standing for "extent," meaning that files would be written in contiguous fashion in the probably ext4 file system in which my openSUSE-12.3 partition of my computer's hard-disk drive was written. So that result was okay. I also entered the command "getfacl /tmp" to obtain an access control list and afterwards saw that the /tmp directory had read, write, and execute permissions for that directory's "Owner," for "Group", and for "Others". In addition there appeared the line "#flags --t" in the output after entering the command "getfacl /tmp". The "t" indicated that the "sticky bit" was set, meaning that only a root user could delete or rename files in the directory /tmp; I assume the same thing would apply to subdirectories of /tmp. As a root user entering the change mode (chmod) command "chmod -t /tmp" to unset the sticky bit did not help to have "1/2" in the .html output resulting from a command of the form "latex2html ...... MyFile.tex". So I reset the sticky bit with the command "chmod +t /tmp". The summary of this paragraph is that I found nothing restrictive in the ordinary or extended attributes of the directory /tmp that should have prevented latex2html from making a subdirectory within it with a name of the form l2h......

The image of the factor of 1/2 needed in equation mode apparently was not written into into a .png (Portable Network Graphics) image file. Please help me solve the problems of making the image of 1/2 appear in equation mode and of enabling LaTeX2HTML to "locate" the file /usr/lib/texmf/tex/latex/html/html.sty.


From: Pat Somerville 
Sent: Tuesday, July 09, 2013 12:49 AM
To: latex2html at tug.org 
Subject: Some mathematical images in my case not fully processed by LaTeX2HTML 1.71 using both an old and a new .tex file

Hello. In March of the year 2013 I upgraded or else performed a "clean" installation from an openSUSE-12.2 to openSUSE-12.3 Linux operating system. Afterward I installed lots of texlive software packages and updates to software packages in the openSUSE-12.3 Linux operating system. I then performed tests on a .tex file using the programs LaTeX and LaTeX2HTML. My notes of March 20, 2013 show that things regarding LaTeX and LaTeX2HTML worked okay in that test. Afterward I think I added one ? to each two lines of computer code in the file /usr/bin/latex2html, following Shigeharu Takeno's kindly provided advice at http://tug.org/mailman/htdig/latex2html/2008-December/003489.html on the Internet. On the same day after making those edits my notes indicate that in a test LaTeX2HTML produced good-looking mathematics. Checking those edits on July 8, 2013 it appeared that gratefully I made them correctly. One unusual thing is that unlike after previous installations of openSUSE and texlive software packages no line reading, except for the double quotation marks, " $DVIPSOPT= ' -Ppdf -E'; " was found in the file /usr/lib/latex2html/l2hconf.pm; so due to not finding such a line of code, it was not commented out, as I had done on one or more earlier occasions again following Shigeharu Takeno's kindly provided advice. I have updated the openSUSE-12.3 Linux operating system, in which I have been using LaTeX2HTML 1.71, numerous times since March 20, 2013, most recently on July 7, 2013.

But on July 8, 2013, while running a "latex2html ......" command on a .tex file, I observed I think a new phenomenon for me (A "latex ....tex" command had already been executed by that time.). After seeing the message reading something like "processing 192 images," unlike what I had seen in the past when processing a new, .tex document, I did not see the image numbers appearing one per line in a terminal program as those images were being processed as the result of a "latex2html...." command being executed. Then afterward when attempting to view the .html document produced by LaTeX2HTML 1.71 I saw inline mathematical images within a paragraph of text displayed correctly. But following that success in the .html file unfortunately I saw some parts of equations appearing in each failed case as "Image" in my installation of the Konqueror Web browser (The problem was also observed in a Mozilla Firefox Web browser.). For example, in the test equation y=(1/2) x**2, with LaTeX code for it appearing as y=\frac{1}{2}x^2, x squared was displayed correctly in equation mode; but for the fraction of one-half instead the word "Image" appeared on what looked something like a software "button." Looking in the folder in which LaTeX2HTML produced the .html output file in one case many Portable Network Graphics (.png) files were there. In a different test case I tried to inspect a .png image file using the program GNU (GNU's Not Unix) Image Manipulation Program (GIMP) and saw the word "Image," but otherwise did not see "1/2" or a portion of an equation. So apparently such images were not completely produced by LaTeX2HTML for a very general reason I later hypothesize here. Unfortunately this "Image" problem occurred when processing both an old and a new .tex file using probably the combination of the programs LaTeX and LaTeX2HTML. On the other hand, when the DeVice-Independent (.dvi) output file produced by LaTeX was viewed in the program Okular, the sampled equations looked good.

In summary, this matter appears complicated because of the many software packages installed in my Linux operating system. But I think I used LaTeX2HTML version 1.71 even before my installation of the openSUSE-12.3 Linux operating system and do not recall ever seeing this exact problem before July 8, 2013. And shortly after the installation of openSUSE 12.3 and some "texlive" software packages and making some updates to software packages within the openSUSE-12.3 system, the programs LaTeX and LaTeX2THML worked okay. My subsequent edits of two lines of code in the file /usr/bin/latex2hml gratefully appear to have been properly made. So a simple hypothesis is that the "Image" problem might have been caused by one or more of the many updates to software packages in openSUSE 12.3 that I have made through Yet Another Software Tool 2 (YaST2) since March 20, 2013. I do have a file called images.log in the .html file's output directory that contains about 349 lines for a test case. Perhaps there could be a clue to the problem within that file. I request that someone please either make a good guess for me of the cause and solution to this problem or else provide for me a diagnostic means by which I could hopefully determine the cause of this problem, such as to look for a certain kind of clue in the file images.log. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/latex2html/attachments/20130711/1e43cf90/attachment.html>

More information about the latex2html mailing list