[l2h] latex2html example broken?!

alessandro basili alessandro.basili at cern.ch
Mon Sep 5 16:06:25 CEST 2011

On 8/8/2011 8:17 PM, alessandro basili wrote:
> It has been a while that I've been through this and I hoped to sort it
> out myself but didn't manage so far.
> I installed the following package:
> [123 at pc456 789]$ latex2html -version
> This is LaTeX2HTML Version 2008 (1.71)
> by Nikos Drakos, Computer Based Learning Unit, University of Leeds.
> on my Fedora Core 11, where latex is installed with the following version:
> [123 at pc456 789]$ latex
> This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
> I did make the example (since I wanted to follow the segmentation
> approach), but the link numbers on the report.html where wrong, while
> everything was fine in the report.dvi and report.ps.
> So looking at the make output I realized that perl had deprecated the $*
> symbol and changed it with /m, so after some struggles I found this patch:
> https://build.opensuse.org/package/view_file?file=latex2html-2008-match-multiline.patch&package=latex2html&project=Publishing&srcmd5=bc1b27d34720a95f26b71ffcd2f58dca
> and applied it to my installation.

I installed the package from scratch to avoid casting any doubts on the
aforementioned patch. But the issue is still the same:


As you may see the "First Subsection" has clearly wrong number.
You may check the make output here:


> I got rid of all the warning for $* but still have a problem when the
> report.aux is checked:

They are back now.

> Processing macros ...,,,, *** Could not find argument for command
> \providecommand ***
> \HyPL at Entry[1]<<56>><<56>>
> Any idea why this is happening?

Still no idea why that is happening.

> Regards,
> Al
> _______________________________________________
> latex2html mailing list
> latex2html at tug.org
> http://tug.org/mailman/listinfo/latex2html

More information about the latex2html mailing list