[l2h] Inconsistent results in a LaTeX2HTML, output, .html file for the command {\mathrsfs {L}} and no script H for the command {\mathrsfs {H}}, each using \usepackage{mathrsfs, ...., ....., .....}

Pat Somerville l_pat_s at hotmail.com
Wed Jun 8 04:54:34 CEST 2011

Thanks, Professor Moore, for kindly taking an interest in the problems I
have been facing, as mentioned in this chain of e-mail letters.  I attached
the three files images.tex, images.log, and images.out for your analysis.
Before I make any further changes of my own, these files should correspond
to the version of the file Throwaway8.tex in my e-mail letter before this
one in this chain of e-mail letters.  You are welcome to use the contents of
the file Throwaway8.tex to experiment or further analyze toward "diagnosing"
the problem with the image for script L_{int}, etc.


From: "Ross Moore" <ross.moore at mq.edu.au>
Sent: Tuesday, June 07, 2011 6:18 PM
To: "Pat Somerville" <l_pat_s at hotmail.com>
Cc: "Latex2Hmtl list" <latex2html at tug.org>
Subject: Re: [l2h] Inconsistent results in a LaTeX2HTML, output, .html file
for the command {\mathrsfs {L}} and no script H for the command {\mathrsfs
{H}}, each using \usepackage{mathrsfs, ...., ....., .....}

> Hello Pat,
> On 08/06/2011, at 7:12 AM, Pat Somerville wrote:
>> Hello again. I had trouble producing a script L_{int}
> Firstly, this would look better as:   $\mathscr{L}_{\mathrm{int}}$
> otherwise the spacing between the letters 'i' 'n' 't' will be wrong,
> as well as the style. Such abbreviations of words with mathematics
> are meant to be in upright text, not slanted.
> (e.g. \log \sin  \cos \tan etc. )
> Secondly, whenever you want constructions like this it is best
> to define your own macro:
>  \newcommand{\Lint}{\mathscr{L}_{\mathrm{int}}}
> or even
>  \newcommand{\Lint}{\ensuremath{\mathscr{L}_{\mathrm{int}}}}
> This simplifies the appearance of your typescript (i.e the body
> of your LaTeX source)
>        Here is a sentence containing $\Lint$.
> especially when you are using it within more complicated expressions.
> e.g.
> \newcommand{\Lint}{\mathscr{L}_{\mathrm{int}}
> \newcommand{\Hint}{\mathscr{H}_{\mathrm{int}}
> \newcommand{\etasigdot}{\dot{\eta }_{\sigma }}
>   $\Hint = \dfrac{\partial \Lint}{\partial \etasigdot}\,\etasigdot - \Lint
> = -\Lint $
>> something like \fontsize{12}{14}\selectfont ${\mathscr {L}}_{int}$,
>> altogether something like this:
>> \begin{equation}
>> \mbox{Here is a sentence containing \fontsize{12}{14}\selectfont
>> ${\mathscr {L}}_{int}$.}
>> \end{equation}
> Why are you specifying sizes like this?
> LaTeX provides macros  \large  \Large  etc.  to do this properly
> and consistently for both the text and math content.
> Stuff like  \fontsize{12}{14}\selectfont  should only ever be used
> within macro expansions, written by experts who have worked through
> every aspect of the consequences.
>> I found a manual for LaTeX2HTML on the Internet at
>> http://www.astr.ku.dk/software/latex2html/manual/node8.htm#SECTION00052100000000000000.
>> According to what I read there to implement a .sty file of the form
>> Name.sty there should be a corresponding file of the form Name.perl
>> within a directory ..../styles. But I did not find any such mathrsfs.perl
>> file in my installation of the directory ..../styles; a search of the
>> entire Internet for mathrsfs.perl also yielded no found results. So I
>> presume that a mathrsfs.perl file might not exist in public.
> That is true. There is no  mathrsfs.perl  with LaTeX2HTML.
> All it does is change the font being used for script letters.
> This is not relevant at all to HTML, when you need to be creating
> images of these characters anyway.
>> Could some of the awkwardness I found using mathrsfs with LaTeX2HTML be
>> because of that?
> LaTeX2HTML always has difficulty making images of script letters,
> because they place ink *outside* the stated typesetting width
> and/or height.
> This means that the black "cropping bars", that LaTeX2HTML uses
> to try to capture the necessary size for an image, are quite likely
> to not catch it all. Then images do not get cropped to the correct
> size. Hence you may see black lines at the left and bottom
> of an image.
>> Assuming so, could one of you familiar with the Perl scripting language
>> suggest a mathrsfs.perl which would minimally enable the implementation
>> of the command \mathscr, apparently used by or within the software
>> package mathrsfs.sty, for various font point sizes and letters of the
>> common Roman alphabet for the English language?
>> Toward "diagnosing" some problems in generating an inline (within text)
>> script L_{int} with the contents below of the file Throwaway8.tex, I
>> tried roughly following a few of the suggestions I found on the Internet
>> by:
>> 1) generating a .tex file I might have called Throwaway9.tex with
>> contents similar to the following:
>> \documentstyle{article}
>> \begin{document}
>> some text \fbox{ more text }
>> \end{document}
>> .
>> I didn't discover any problems as a result of executing the command
>> "latex Throwaway9.tex".
> You will never see problems this way.
> To get an idea of what may be going wrong, you need to do
>     latex images.tex
> where the file images.tex was created by a fresh run
> of LaTeX2HTML, within a subdirectory of the directory
> where your LaTeX source resides.
> Best is to use   latex2html -debug ....
> so that all temporary files are retained.
> Then you can look at all aspects of what was done.
>> 2) As a result of executing the command "latex Throwaway8.tex", with the
>> file Throwaway8.tex containing the contents below, I saw messages like
>> "Font shape 'U/rsfs/m/n' in size <13> not available
>> size <12> substituted in input line 10". But apparently that was
>> inconsequential because the inline script L_{int} was gratefully
>> displayed well in the resulting output file Throwaway8.dvi when viewed in
>> the program Okular.
>> 3) inputting the command: dvips -o Throwaway8.ps Throwaway8.dvi
>> My notes do not indicate any problems that command.
>> 4) inputting the command: gs -dNODISPLAY pstoppm.ps
> Why?
> What is the file  pstoppm.ps ?
> You shouldn't have a file of this name as part of your job.
> Shouldn't it be   Throwaway8.ps  ???
>> Error: /undefinedfilename in (pstoppm.ps)
>> ...
>> Last OS error: 2
>> GPL Ghostscript 9.00: Unrecoverable error, exit code 1
>> 5) inputting the command: pnmcrop Throwaway8.ppm >Throwaway8.crop.ppm
>> pnmcrop: Unable to open file 'Throwaway8.ppm' for reading ....(No such
>> file or directory)
>> 6) After running a latex2html command on the file Throwaway8.tex to
>> generage png (Portable Network Graphics) images, I found the following
>> messages:
>> pnmcrop: The image is entirely background; there is nothing to crop.
>> pstoimg: Error: "/usr/bin/pnmcrop -verbose -sides -bot <
>> /tmp/l2h5852/p5934.pnm > /tmp/l2h5852/p5934.t02" failed:
>> Image "/tmp/l2h5852/p5934.pnm" is PPM, 4x5
>> Running "/usr/bin/ppmquant -floyd 256 < /tmp/l2h5852/p5934.pnm |
>> /usr/bin/pnmtopng -interlace -trans 'gray85' > img6.png"
>> .
>> In the file images.log a missing } was reported and reported as inserted,
> That spells trouble.
> I suspect that your use of unnecessary macros like  \fontsize
> and  \selectfont  has screwed things up significantly.
> Send me the images.tex file, because that certainly will contain
> the clues as to what is going wrong.
>> apparently associated with a mathscr-containing line in Throwaway8.tex.
>> But the program LaTeX did not display such a message in the same
>> terminal-program window in which the command "latex Throwaway8.tex" was
>> entered using the same file Throwaway8.tex. As a result of latex2html
>> executions it has been common to see the messages
>> "
>> *********** WARNINGS ***********
>> No implementation found for style `mathrsfs'
>> No implementation found for style `hyperref'
>> Unknown math command: \mathscr , image needed.
>> Done."
>> displayed after inputting a latex2html command on a file like
>> Throwaway8.html. The message "No implementation found for style
>> `hyperref'" is understandable because, except within
>> \usepackage{....,...,hyperref,......}, I did not use \hyperref in my
>> current file Throwaway8.tex. However, the messages "No implementation
>> found for style `mathrsfs'" and "Unknown math command: \mathscr, image
>> needed" are strange because the mathrsfs-package command \mathscr does
>> appear several times within the file Throwaway8.tex.--So I guess that
>> these messages might mean that LaTeX2HTML did not recognize one or more
>> appearances of \mathscr within Throwaway8.tex; or perhaps some part of
>> LaTeX2HTML could not work with \mathscr because no image was produced
>> which could be associated with that command(??).
>> Please help with an answer to a question above, an explanation of the
>> cause of the problems with the Ralph Smith Formal Script (rsfs) package
>> mathrsfs using LaTeX2HTML, and/or solutions which are less awkward than
>> the "workaround" solutions of which I wrote in this chain of e-mail
>> letters. Thanks for your consideration.
>> Pat
> Hope this helps,
> Ross
> ------------------------------------------------------------------------
> Ross Moore                                       ross.moore at mq.edu.au
> Mathematics Department                           office: E7A-419
> Macquarie University                             tel: +61 (0)2 9850 8955
> Sydney, Australia  2109                          fax: +61 (0)2 9850 8114
> ------------------------------------------------------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: images.tex
Type: application/octet-stream
Size: 7712 bytes
Desc: not available
URL: <http://tug.org/pipermail/latex2html/attachments/20110607/adbce6ca/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: images.log
Type: application/octet-stream
Size: 16225 bytes
Desc: not available
URL: <http://tug.org/pipermail/latex2html/attachments/20110607/adbce6ca/attachment-0003.obj>

More information about the latex2html mailing list