[l2h] possible configuration bugs

Scott D. Anderson Scott D. Anderson" <anderson@kefalonia.wellesley.edu
Thu, 7 Sep 2000 19:16:17 -0400 (EDT)

I'm a big fan of latex2html, which I used to run on a different machine,
so I was looking forward to getting it on my new machine running Red Hat
6.2.  I previously had installed version 96.1 from a friend's diskette,
but something wasn't working.  So, I figured I'd upgrade.

I just downloaded latex2html-99.2beta8 from
http://saftsack.fs.uni-bayreuth.de/~latex2ht/current/.  I put it in /tmp,
and untarred it. I read the INSTALL document and I edited prefs.pm to say
that the icons will live in my public_html directory on our local web
server (not my machine).  (I'll guess I have to remember to copy them
there myself, I think, since the install script isn't likely to be able to
FTP them to my account on a different machine.)  I also told it to
generate good fonts (PK=1).  Otherwise, prefs.pm is unchanged.  Here are
the diffs:

< $prefs{'ICONPATH'} = 'http://cs.wellesley.edu/~anderson/latex2html-icons';
> $prefs{'ICONPATH'} = '';
< $prefs{'PK'} = 1;
> $prefs{'PK'} = 0;

Then, I ran ./configure and got the following error:

checking for ghostscript library and font paths... no
Warning: Could not determine GS_LIB path.
	 Ghostscript may not work due to missing startup files.
	 You need to set the value of GS_LIB manually in cfgcache.pm.
Hint:    Search for the file 'gs_init.ps'. This directory and the 'fonts'
	 directory (usually same level) should be set in GS_LIB.
	 Separate the entries with the ":" character. The current
	 directory "." should be included, too.

I found gs_init.ps in /usr/share/ghostscript/5.50/, but there is no fonts
directory.  I set GS_LIB to export GS_LIB=.:/usr/share/ghostscript/5.50/
and tried again, with no luck.

So, I edited cfgcache.pm by hand, thus:

$cfg{'GS_LIB'} = q'/usr/share/ghostscript/5.50/';

and crossed my fingers.  It seemed to work on my test files; at least,
there are png files being generated, and I think gs does that.

I then did "make install" which ran okay except for the following error:

Error (Copy): Copy "./latex2html" to "/usr/local/bin/latex2html" failed: No such file or directory
 at config/install.pl line 397

This turned out to be a misleading error message.  The problem was that
there was a leftover in /usr/local/bin from an earlier version Of
latex2html.  I just deleted the old file (actually, a symbolic link) and
copied the executable by hand.  

With latex2html installed, I re-ran it on my test files, and got the
following error message:

kefalonia lectures/ latex2html 01-intro.tex 
Can't locate L2hos.pm in @INC (@INC contains: /usr/lib/perl5/5.00503/i386-linux /usr/lib/perl5/5.00503 /usr/lib/perl5/site_perl/5.005/i386-linux /usr/lib/perl5/site_perl/5.005 . /usr/local/lib/latex2html) at /usr/local/bin/latex2html line 83.
BEGIN failed--compilation aborted at /usr/local/bin/latex2html line 83.

This turned out to be because when I did the "make install," I was "root,"
which has a umask of 007, so that the /usr/local/lib/latex2html directory
and all subdirectories and files were unreadable.  I fixed that with:

find /usr/local/lib/latex2html -type d -exec chmod a+rx {} \;
find /usr/local/lib/latex2html -type f -exec chmod a+r {} \;

That fixed that problem and it seems to mostly work at this point.  I
haven't done extensive testing.

So, I have three points:
(1) Can the GS_LIB configuration problem be fixed?  Did I do something
(2) Can the "make install" script check for files existing and give a more
sensible error message?
(3) Maybe root's umask shouldn't be 007 (it seems like a good security
thing, but I don't know), but I think "make install" should check, or
check the permissions on the directories and files it creates.

Thanks for all your hard work on latex2html.  I hope my experience can
make someone else's installation easier.  



Scott D. Anderson
Wellesley College, Wellesley, Massachusetts