[l2h] Installation problems on a PC

Anders Blom Anders Blom <blom@teorfys.lu.se>
Mon, 28 Jun 1999 10:01:26 +0200

I recently installed latex2html 982b7dos (latest sharp PC version?) on
my Win98 PC, and ran into all sorts of problems. They should be quite
general, so I would like to bring them to your attention.

1) There seems to be confusion between the labels "dos" and "MSWin32" in
"install-test". I had to manually change them on line 389 in
"install-test" to get it running. By default it tried to use unix-style
shell command (`sh and so
on), but not for MSWin32. But for dos, which was what I had (I never
changed it myself, it was what I got just from running) it then uses the
unix-style, which will not work. So, either default should be
"find_executable" or there should be an "or" to test for MSWin32 OR dos.

2) The install script fails to update "local.pm" if it exists; it
just uses the old settings even if you would like to change something.
Also, there seems to be confusion between "local.pm" and "localdos.pm"
-- at
some point the latex2html script tried to use the one which was not
updated. (Maybe I did things in the wrong order to get this error, but
it is nevertheless confusing to have both files present, not knowing
which is valid.)

3) Same confusion goes for "l2h-conf" and "latex2html.config"

4) The dvips supplied with some packages, such as MikTeX 1.20 that I
use, has
a somewhat different output from "dvips -f DUMMY" which prevents the
current script from detecting the version number. Output is:

This is dvips 5.83 (MiKTeX 1.20b) Copyright 1998 Radical Eye Software

So even if the version is 5.83, install-test will warn about wrong
version. Inexperienced users may be frightened.

4) RATHER SEVERE PROBLEM (at least it kept me going for 2 days to locate
the source of it): The "pnmcrop" supplied elsewhere (such as with
MikTeX) has a different calling argument list, which will cause ps2img-n
to fail. If configure-pstoimg happens to find this before the one
supplied with latex2html, thing go very wrong.

It is not so easy to spot this error, especially for the following
reason: On exit, latex2html tells about some image conversion problems,
and refers to the manual. Since no ppm files can be found, the natural
idea is that ghostscript failed to generate ppm files.

Hence one looks up the steps in Troubleshooting (on pages 80-81; July 3,
1997 version) regarding this, and is adviced to latex a small test file,
dvips it and then run ghostscript with "pstoppm(3).ps".
BUT: the pstoppm.ps files use "writeppmfile" which is made **obsolete**
in GS 3.3 which is the current version!
So: the manual should be updated to not advice this, since it will guide
the troubleshooter in a very wrong direction, viz. to search for
ghostscript errors, and trying to downgrade to earlier versions etc.
which I have been trying for a long time now. Further, it should be made
public that not all versions of pnmcrop are interchangeable.

I suppose by using the "-debug" option I would have detected this
earlier than I did, but I was so sure it was a ghostscript error because
of the non-existence of any ppm-files. It seems somewhere along the way,
the ppm-files which indeed were generated, were deleted.

Well, I hope this is of some help! I would be happy to hear some
comments on these matters. Probably some of it is due my own
inabilities  (I am not a perl programmer, only c and pascal) and not
real bugs in latex2html, but then again, they really made the
installation/running impossible.

I should also add, that to get GNU Make 3.77 (latest) to generate the
html-version of the manual is basically hopeless on a PC. You have to
apply all sorts of tricks to the Makefile, and it still stoppes halfway.
I seems there is trouble with semicolons at the end of lines, and also
on a PC the command to invoke l2h must be "perl latex2html". If you
then, as I liked to do, use a .bat-file to do this, so that you still
can call it with just "latex2html *.tex", WinDOS will strip off any
commas on the command line, so "-html_version 3.2,math" comes out
"-html_version 3.2 math", and so l2h tries to work on "math.tex".

Anders Blom
Solid State Physics
Dept. of Theoretical Physics, Lund University