[texworks] Texworks quit working (on windows)

K. Frank kfrank29.c at gmail.com
Sat Oct 15 01:40:14 CEST 2011

Hello Stefan!

On Fri, Oct 14, 2011 at 5:36 AM, Stefan Löffler <st.loeffler at gmail.com> wrote:
> Hi,
> Am 2011-10-04 19:05, schrieb K. Frank:
>> Again, thanks to you and everyone else who helped out.  I'm happy
>> to offer myself up as a sacrificial lamb to keep trying to diagnose this
>> problem, if anyone would find that helpful.
> Thanks for that (very generous!) offer. I definitely want to investigate
> this further, however I have little time to do so right now, unfortunately.
> Could you try running the latest version of Tw under a new user? Does it
> work there?

Yes, TeXworks launches for a new user.

Just to recap my situation:

I have TeX Live installed, and I have two versions of TeXworks "installed" (in
addition to the TeXworks that came bundled with TeX Live).  By "installed"
I mean that I unzipped the TeXworks download into a directory I set up for it.

My two versions are r932 (recent, if not the latest, and the one I've been
having trouble with) and r466 (one that was suggested earlier in this thread,
and is perhaps pre-python, and that seems to be working fine for me).

I launch TeXworks by clicking on TeXworks.exe in windows explorer.

First I checked my current status.  r932 doesn't launch (it exits almost
immediately).  r466 launches and appears to run correctly.

I then created a new user.  Logged in as the new user, I can launch both
r932 and r466, and they appear to run (but I didn't try editing or typesetting
any files with them).

I then logged back in as my original user and verified that r932 still doesn't
launch, while r466 does.

Again, this is on 64-bit windows 7, and, as far as I know, all of the TeX
stuff (both TeXworks and TeX Live) is 32 bit.

So, presumably this means that the user configuration for TeXworks is
corrupted somehow.  But in one of my earlier tests I had nuked the user
directory for TeXworks and that didn't clear things up.

Now, the new user does have a new-user path.  But I had also tried
launching TeXworks from a null-path command prompt, so presumably
that test ruled out any path issues.

> Cheers,
> Stefan

Thanks again for your help.

K. Frank

More information about the texworks mailing list