[texworks] Texworks quit working (on windows)

K. Frank kfrank29.c at gmail.com
Sat Oct 29 03:01:15 CEST 2011

Hello All!

Problem solved.  A bogus PYTHONHOME environment variable was

I had installed an application that used python on a removable drive.
It was one of those download-and-run a small web-installer application,
so I never really knew what the install process entailed.  It defined
PYTHONHOME pointing to the generally absent removable drive, a
detail I hadn't noticed.

Anyway, I removed (renamed, actually) the PYTHONHOME variable,
and TeXworks launches properly now.

I suppose that the python-enabled TeXworks uses the following logic:
Check if PYTHONHOME is defined.  If not, run correctly, but without
python.  If it is defined properly, run with python enabled.  If it is defined
improperly, exit silently.

Further minor comments appear below:

On Fri, Oct 14, 2011 at 7:40 PM, K. Frank <kfrank29.c at gmail.com> wrote:
> Hello Stefan!
> On Fri, Oct 14, 2011 at 5:36 AM, Stefan Löffler <st.loeffler at gmail.com> wrote:
>> Hi,
>> Am 2011-10-04 19:05, schrieb K. Frank:
>>> Again, thanks to you and everyone else who helped out.  I'm happy
>>> to offer myself up as a sacrificial lamb to keep trying to diagnose this
>>> problem, if anyone would find that helpful.
>> Thanks for that (very generous!) offer. I definitely want to investigate
>> this further, however I have little time to do so right now, unfortunately.
>> Could you try running the latest version of Tw under a new user? Does it
>> work there?
> Yes, TeXworks launches for a new user.

The bogus PYTHONHOME environment variable was a user, rather than
a system variable, explaining why the problem didn't occur for the new

> Just to recap my situation:
> I have TeX Live installed, and I have two versions of TeXworks "installed" (in
> addition to the TeXworks that came bundled with TeX Live).  By "installed"
> I mean that I unzipped the TeXworks download into a directory I set up for it.
> My two versions are r932 (recent, if not the latest, and the one I've been
> having trouble with) and r466 (one that was suggested earlier in this thread,
> and is perhaps pre-python, and that seems to be working fine for me).

All my versions of TeXworks now launch and seem to run correctly:
the free-standing version (r932), the version that came bundled with
TeX Live (r858), and the pre-python version (r466).

> I launch TeXworks by clicking on TeXworks.exe in windows explorer.
> First I checked my current status.  r932 doesn't launch (it exits almost
> immediately).  r466 launches and appears to run correctly.
> I then created a new user.  Logged in as the new user, I can launch both
> r932 and r466, and they appear to run (but I didn't try editing or typesetting
> any files with them).
> I then logged back in as my original user and verified that r932 still doesn't
> launch, while r466 does.
> ...
> So, presumably this means that the user configuration for TeXworks is
> corrupted somehow.  But in one of my earlier tests I had nuked the user
> directory for TeXworks and that didn't clear things up.
> Now, the new user does have a new-user path.  But I had also tried
> launching TeXworks from a null-path command prompt, so presumably
> that test ruled out any path issues.

But, of course, I hadn't tried launching TeXworks from a null-PYTHONHOME
command prompt...

>> Cheers,
>> Stefan
> Thanks again for your help.
> K. Frank

Thanks to all.

K. Frank

More information about the texworks mailing list