[texworks] Window Show Tags and Window Show Contents

Stefan Löffler st.loeffler at gmail.com
Tue Sep 8 15:20:07 CEST 2009

Hi Paul,

Paul A Norman schrieb:

> > I'm on WinXP Pro using the latest TW Lua release for Windows, which is
> > still 0.1 ver 366 I think.
> >
> > Yes both the Windows show up,
> >        Sometimes the tag contents in the Pdf doesn't show up, but mostly
> > it does (with the same document each time)
> >   

Actually, this behavior should always be the same, unless you retypeset
your document or change it in another way (in which case some of the
internal toc data may get mixed up).

> >        However the editor tags window only ever has "No Tags" in the top
> > and some fine dots.
> >   

OK, this raises another few questions:
 * Did you try quitting and restarting Tw? I experienced some weird
behavior just now (the tags did show up, but didn't get updated when I
changed something) which went away after reloading the file.
 * Did you try adding a line like
%:My Bookmark
AFAIK this is not well documented yet (I'm going to put it on the wiki),
but it should add bookmarks to the tag window so you can jump to
arbitrary places in your sources.
 * Did you try with the most recent standard build (i.e. those on Tw's
Google Code page)? This may be related to Alain's (experimental) Lua
build, in which case we'd have to investigate in a totally different


PS: Sorry Paul for sending you this message multiple times. I realized too late that your last message didn't go to the mailing list but to me personally. Please use the "Reply to all" button of your mail program (on this message from the mailing list) in the future so that everyone reading the list can benefit from the discussion.

More information about the texworks mailing list