[texworks] Building TeXworks on Windows using MinGW

Stefan Löffler st.loeffler at gmail.com
Sun Jun 14 09:37:15 CEST 2009

On 2009-06-14 02:08, T T wrote:
> On 13/06/2009, T T <t34www at googlemail.com> wrote:
>> Now, I followed all the steps and also further directions from this
>> thread and I managed to compile something (not yet sure what) but it
>> doesn't work. When I start texworks.exe (release version) it
>> complaints about missing dlls. I have copied the ones I could find but
>> I don't see libxml2.dll anywhere.
> OK, I added libxml2.dll and also iconv.dll was needed (both from KDE)
> but now I get the following error when starting TeXworks:

Ok, thanks. I had some strange usage of those two libraries as well, but
didn't think much about it. I probably had them installed with some
other application (like the GIMP). But since they are available from KDE
on Windows it's simple enough to install them as well.

> The procedure entry point _ZN8QPPaiter9drawImageERK7QPointFRK6QImage
> could not be located in the dynamic link library QtGui4.dll.
> Aren't those KDE libs supposed to work? I chose the ones for mingw in
> KDE installer. I'm stuck :(

Yes, they are supposed to work. I think I had a similar problem, but I
think you won't be able to confirm that because MinGW doesn't come with
a dll dependency walker. In my case, this problem didn't come from QtGui
directly (as used in TW). Instead, poppler-qt4 used an incompatible
version of QtGui - don't ask me how this could happen. In any case, the
problem was solved for me by reinstalling (at least) poppler-qt4 and
poppler from a different server (the one that was broken in my case was
a french server). If this doesn't help, try reinstalling the rest of the
libraries, and probably rebuilding TW to be on the safe side.

If this still doesn't work: the dependecy walker can apparently be
downloaded at http://www.dependencywalker.com/. It's not an easy tool to
use (it's intended for hard-core developers ;)), but if you see a red
QtGui.dll under libpoppler-qt4 on the left which - when you click on it
- displays a single red line on the right giving the function you posted
(_ZN8QPPaiter9drawImageERK7QPointFRK6QImage) it's probably the same issue.


More information about the texworks mailing list