[texworks] Building TeXworks on Windows using MinGW

T T t34www at googlemail.com
Sun Jun 14 11:11:15 CEST 2009

On 14/06/2009, Stefan Löffler <st.loeffler at gmail.com> wrote:
> On 2009-06-14 02:08, T T wrote:
>> Aren't those KDE libs supposed to work? I chose the ones for mingw in
>> KDE installer. I'm stuck :(
> Yes, they are supposed to work. I think I had a similar problem, but I
> think you won't be able to confirm that because MinGW doesn't come with
> a dll dependency walker. In my case, this problem didn't come from QtGui
> directly (as used in TW). Instead, poppler-qt4 used an incompatible
> version of QtGui - don't ask me how this could happen. In any case, the
> problem was solved for me by reinstalling (at least) poppler-qt4 and
> poppler from a different server (the one that was broken in my case was
> a french server). If this doesn't help, try reinstalling the rest of the
> libraries, and probably rebuilding TW to be on the safe side.

Didn't work :( I tried several KDE mirrors with the same results.

If what you say is true, that would really suck. How people are
supposed to know which KDE mirror to use? Do you remember which one
you used?

Does gcc version matters? I have gcc 3.4.5 (mingw-vista special r3).

> If this still doesn't work: the dependecy walker can apparently be
> downloaded at http://www.dependencywalker.com/. It's not an easy tool to
> use (it's intended for hard-core developers ;)), but if you see a red
> QtGui.dll under libpoppler-qt4 on the left which - when you click on it
> - displays a single red line on the right giving the function you posted
> (_ZN8QPPaiter9drawImageERK7QPointFRK6QImage) it's probably the same issue.

Yes, that's what I see, _ZN8QPainter9drawImageERK7QPointFRK6QImage as
the only one in red. QtGui4.dll contains

What am I supposed to do about it?



More information about the texworks mailing list