[texworks] Building TeXworks on Windows using MinGW

Alain Delmotte esperanto at swing.be
Sat Jun 13 11:24:59 CEST 2009


Stefan Löffler a écrit :
> Hi,
> On 2009-06-12 21:37, Alain Delmotte wrote:
>> I did install everything.
>> Compiling hunspell went, I think, well; but there were warnings!
> Warnings are OK ;). You should end up with
> C:\texworks\hunspell-1.2.8\src\hunspell\.libs\libhunspell-1.2.a

That's what I got (with other files in libs)
I had to do it from the console of MSYS, because "./configure" doesn't 
make sense in a DOS prompt box

>> For texworks, after modifying texworks.pro, qmake created 3 files:
>> Makefile, Makefile.Release and Makefile.debug
> That's fine, too. It's the way mingw32-make works. There are a few
> things I noticed/would suggest:
> 1) I missed a few changes that didn't fit the guide (they came from my
> local installation, which doesn't quite conform to my guide ;)). The
> three lines in TeXworks.pro should read
>     INCLUDEPATH += C:/KDE/include/poppler/qt4
>     INCLUDEPATH += C:/texworks/hunspell-1.2.8/src/hunspell
>     LIBS += -LC:/texworks/hunspell-1.2.8/src/hunspell/.libs
> unless you changed the directory yourself. This probably isn't the cause
> for the problems here, but would create new ones later.

Here are my directories:

and the modification of TeXworls.pro:
win32 { # paths here are specific to my cross-compilation setup
    INCLUDEPATH += C:/Programmes/KDE-mingw/include/poppler/qt4
    INCLUDEPATH += C:/texworks-mingw/hunspell-1.2.8/src/hunspell

    LIBS += -LC:/texworks-mingw/hunspell-1.2.8/src/hunspell/.libs

KDE-mingw is not in Program Files as this was not advisable for the 
space and it is parallel to KDE for msvc.
The texworks-mingw is parallel to the texworks for MSVC 2005; in fact I 
did first use the msvc directory for mingw, but after I created totally 
separated directories.

The error from mingw32-make is:

mingw32-make -f Makefile.Release
mingw32-make[1]: Entering directory `/c/texworks-mingw/texworks'
Makefile.Release:115: *** missing separator.  Stop.
mingw32-make[1]: Leaving directory `/c/texworks-mingw/texworks'
mingw32-make: *** [release] Error 2

> 2) In the error message, it says "/c/texworks/texworks". Normally, I'd
> expect it to be "/c/texworks/texworks-read-only". Can you confirm this
> and what's your path to TW?
> 3) The error message "/c/texworks/texworks" suggests that you tried to
> run either qmake or mingw32-make (or both) from inside MSYS, which you
> shouldn't. Is that right? (I think this line should read something like
> "C:/texworks/texworks-read-only"

I got the same error from the MSYS console or from a DOS prompt box

> 4) What path does "qmake --version" give you? Is it the correct path to
> your MinGW KDE libs (if it's not, you probably have to adjust your PATH
> and/or KDELIBS environmental variables as documented on the KDE on
> Windows page which is linked from the wiki).

QMake version 2.01a
Using Qt version 4.4.3 C:/Programmes/KDE/bin/../lib

There it is (?) it should be KDE-mingw!
So I renamed "qmake" into "min-qmake" and I could use "make", but with 
errors, see attached file for the output of compilation.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: mingw32-make_compilation.log
URL: <http://tug.org/pipermail/texworks/attachments/20090613/5aa22b37/attachment.pl>

More information about the texworks mailing list