[texworks] Building TeXworks on Windows using MinGW

Stefan Löffler st.loeffler at gmail.com
Sat Jun 13 09:54:34 CEST 2009


On 2009-06-12 21:37, Alain Delmotte wrote:
> I did install everything.
> Compiling hunspell went, I think, well; but there were warnings!

Warnings are OK ;). You should end up with

> For texworks, after modifying texworks.pro, qmake created 3 files:
> Makefile, Makefile.Release and Makefile.debug

That's fine, too. It's the way mingw32-make works. There are a few
things I noticed/would suggest:
1) I missed a few changes that didn't fit the guide (they came from my
local installation, which doesn't quite conform to my guide ;)). The
three lines in TeXworks.pro should read
    INCLUDEPATH += C:/KDE/include/poppler/qt4
    INCLUDEPATH += C:/texworks/hunspell-1.2.8/src/hunspell
    LIBS += -LC:/texworks/hunspell-1.2.8/src/hunspell/.libs
unless you changed the directory yourself. This probably isn't the cause
for the problems here, but would create new ones later.

2) In the error message, it says "/c/texworks/texworks". Normally, I'd
expect it to be "/c/texworks/texworks-read-only". Can you confirm this
and what's your path to TW?

3) The error message "/c/texworks/texworks" suggests that you tried to
run either qmake or mingw32-make (or both) from inside MSYS, which you
shouldn't. Is that right? (I think this line should read something like

4) What path does "qmake --version" give you? Is it the correct path to
your MinGW KDE libs (if it's not, you probably have to adjust your PATH
and/or KDELIBS environmental variables as documented on the KDE on
Windows page which is linked from the wiki).

> mingw32-make stopped with an error:
> C:\texworks\texworks>mingw32-make
> mingw32-make -f Makefile.Release
> mingw32-make[1]: Entering directory `/c/texworks/texworks'
> Makefile.Release:115: *** missing separator.  Stop.
> mingw32-make[1]: Leaving directory `/c/texworks/texworks'
> mingw32-make: *** [release] Error 2
> I attach the three makefiles

They do indeed have some subtle differences to the makefiles with which
it worked on my PC. E.g. they have "<<" on the line where the error
occurred, which mine don't. Anyway, we both have the same qmake version
(2.01a) and Qt version (4.4.3), so that shouldn't be the problem.

> The same with the special make from make-3.81-MSYS-1.0.11-2.tar.bz2
> and the make from msys

There are special makes? In any case, I don't remeber installing any
special MSYS make applications, so I recommend not doing that just yet.
This probably just increases the number of potential problems because
then we can have even more programs that get mixed up.


More information about the texworks mailing list