[OS X TeX] apa.cls comment following \end{table} bug

Scott Allen allens at uleth.ca
Fri May 16 18:52:50 CEST 2008

Hi all,
I've run across a strange issue (bug?) using apa.cls with the latest  
TeX Live distribution (2007).
I'm using TeXshop v2.14 and apa.cls v. 1.3.2

The easiest way to generate the problem is to take Athanassios  
Protopapas's "apaexample.tex" file that he includes with the aps.cls  
package (from CTAN) and add a "%" (to start a comment) following the  
"\end{table}" command following the only table in the short document.   
Placing a comment following that command causes no problems if you  
typeset the document using the [jou] (for journal) or the [doc] (for  
document) switch but if you use the {man] (for manuscript) switch, the  
document won't typeset and the console shows the error:

! File ended while scanning use of \next.
<inserted text>
<'> apaexample.tex

Placing a comment following the "\begin{table}" command causes no such  
problems, so I guess the work-around is not to place comments on  
following an "\end{table}" command.

I've posted example files and outputs at:

I've posted it here so that:
a) Anyone who runs across the error might know how to fix it.
b) Anyone who has the skills to fix the problem (way beyond my  
abilities) might wish to do so.


Dr. Scott Allen,
Associate Professor and Associate Chair,
Department of Psychology
The University of Lethbridge
Lethbridge, AB, Canada, T1K 3M4
(403) 329-2077
allens at uleth.ca

More information about the macostex-archives mailing list