[OS X TeX] Beamer problems - mktexmf?

Axel E. Retif axel.retif at mac.com
Wed May 7 10:51:49 CEST 2008

On  6 May, 2008, at 12:54, Jo Willmott wrote:

> I have just set up a new Mac with MacTex 2007. I've previously been  
> on a PC, using MikTex. I've transferred across my files and am  
> having some problems. I've tried looking for answers but am not  
> finding any, so wonder if any of you can help.
> The main problem has to do with Beamer. It is having difficulty  
> with various fonts, mainly large or italic Greek fonts and also  
> certain symbols (eg \XSolidBrush).

Can you provide a minimal non-working example, so we can test it?  
Your preamble and one frame would be enough.


> I found this fix, but it seems only to apply to Windows users.
> 	The Windows TeX programs do not invoke mktexmf by default. Thus,  
> for instance, the lh 	fonts to support Cyrillic will not be found.  
> One workaround is to make these settings in your texmf.cnf  
> (kpsewhich texmf.cnf should find the file, and searching for  
> MKTEXMF will find the section; some commented-out assignments are  
> present):
> 	MKTEXPK = 1
> 	MKTEXMF = 1
> I searched for the file (texmf.cnf), but can't find it (using  
> Terminal locate).

Your locate database hasn't been built yet (at least up to OS X 10.4,  
it builds on Saturdays at 03:15, provided, of course, your machine is  

Now ---I **definitely wouldn't change** texmf.cnf, but you can find  
it with

find /usr/local/texlive -name texmf.cnf


kpsewhich texmf.cnf

In Terminal.app try `` man find '' and `` texdoc kpathsea ''.



More information about the macostex-archives mailing list