[Xy-pic] tilted ~

Michael Barr barr at math.mcgill.ca
Mon Aug 22 14:27:56 CEST 2011

I tried to add
and \pdfoutput1
to my file as suggested by Daniel Müllner and got the following messages:
Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
("C:\MiKTeX 2.8\tex\latex\base\size10.clo"))
("C:\MiKTeX 2.8\tex\generic\xypic\xy.sty"
("C:\MiKTeX 2.8\tex\generic\xypic\xy.tex" Bootstrap'ing: catcodes, 
("C:\MiKTeX 2.8\tex\generic\xypic\xyrecat.tex")
("C:\MiKTeX 2.8\tex\generic\xypic\xyidioms.tex")

  Xy-pic version 3.7 <1999/02/16>
  Copyright (c) 1991-1998 by Kristoffer H. Rose <krisrose at ens-lyon.fr>
  Xy-pic is free software: see the User's Guide for details.

Loading kernel: messages; fonts; allocations: state, direction,
utility macros; pictures: \xy, positions, objects, decorations;
kernel objects: directionals, circles, text; options; algorithms: 
edges, connections;  Xy-pic loaded)
("C:\MiKTeX 2.8\tex\generic\xypic\xyarrow.tex"
  Xy-pic option: Arrow and Path feature v.3.5 path, \ar, loaded)
! Xy-pic error: No `pdf@@@' option.
\xyerror@ ...#2}\fi \errmessage {Xy-pic error: #1}

? x
No pages of output.

Note that this version of xy-pic is dated 1999.  But it is what came with 
Miktex 2.8 (version of 2010) since I used a clean installation from a 
TeX-Live CD on a new computer.  My User's guide and Reference Manuals are 
also dated 1999 and refer to v. 3.7, the one I am using, and does not 
mention a pdf option.  There is a dvips option but when I tried that, the 
output consisted only of the nodes A and B.

Next I went to CTAN and found that the current version is 3.11 (obviously, 
the Miktex program has not caught up with this).  I downloaded the zip 
file and unzipped it, but there is no automatic installation program and 
the instructions, at least for a Windows user, are not at all obvious. 
Also I am afraid to install over the old installation.  So I copied the 
file xypic.tex to the directory that contains things like xyarrow.tex and 
tried the option pdf.  That still resulted in the error message "No pdf@@@ 
option".  Finally I tried adding dvipdf.tex to my working directory and 
simply inputting it.  That resulted in no error message, but the diagram 
was in no way improved.

Michael Barr

More information about the xy-pic mailing list