MikTeX fails to find a font installed in Windows 10 (for XeLaTeX)

BPJ bpj at melroch.se
Wed Mar 27 22:32:32 CET 2019

Have you tried omitting " Regular"?

Den mån 25 mars 2019 17:00P P Narayanaswami <swami at mun.ca> skrev:

> I have problem using some open type fonts in Windows 10 with XeLaTeX in
> MikTeX.
> I downloaded a Malayalam language font, "Gayathri" and tried to use it
> in XeLaTeX.
> This font is clearly listed in the Font catalogue accessible from
> Control Panel.
> The Font catalogue lists its name as "Gayathri Regular".
> But when I use them in XeLaTeX with the command
>       \newfontfamily{\mal}[Script=Malayalam]{Gayathri Regular}
> MikTeX complains it cannot find the font and starts building 'tfm's,
> with the following Error message.
>       Package fontspec Error: "Gayathri Regular" cannot be found.
> I had the same problem with many other fonts in many other languages
> too.
> I guess it must be a  problem related to the way MikTeX identifying the
> fonts in the operating system.
> Another Malayalam language font "Kartika" that comes with Windows 10
> (when I installed the
> Malayalam language add-on in Windows 10) works fine in XelaTeX.  Hence I
> am puzzled.
> Any help will be appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://tug.org/pipermail/xetex/attachments/20190327/6989a251/attachment.html>

More information about the XeTeX mailing list