[XeTeX] version issue? font issue

maxwell maxwell at umiacs.umd.edu
Wed Jan 18 00:29:28 CET 2017

I'm working with a font developer to track down a problem.  We've been 
getting their betas (and before that, their alphas) of a Nasta'liq font. 
  Up until this last version, the joining of characters worked fine; with 
their latest version, there is no joining.  Except it works on their 
(Windows) machine, it only fails on my (Linux) machine.  Not only can't 
we figure out why the characters don't join when they should on my 
machine, we don't understand why it would work on one machine and not 
the other.  And since they can't reproduce the issue on their machine, 
it's hard for them to know how to fix it.

The font requires Graphite (in all versions we've tested).

I have verified that simply switching between the two beta versions on 
my machine toggles the joining behavior.

My xetex says:
     XeTeX 3.14159265-2.6-0.99996 (TeX Live 2016)
     Compiled with Graphite2 version 1.3.8; using 1.3.8
Their xetex says:
     This is XeTeX, Version 3.14159265-2.6-0.99996 (TeX Live 2016/W32TeX) 
(preloaded format=xetex)
(I'm not sure what version of Graphite they have, but theirs is the one 
that's working.)

My version of xetex is a 64-bit version, theirs appears to be 32-bit, if 
I'm reading the above correctly.  I suppose something could be different 
in the two versions...  I don't have the 32-bit version of xetex 
installed, but I guess I could do so.  (Presumably Windows and Linux 
versions also differ.)

I had previously seen a failure in a similar situation where we had a 
woff font whose filename was the same except for the ".woff".  But this 
time there are no .woff files laying around.  I've also looked for other 
copies of the font, but find none (and fc-list is pointing to the 
correct one).

Any suggestions on where we should look?  Either in the font, or in 
xetex itself.  (There's obviously an issue with the new version of the 
font, since earlier versions worked; but given that their copy of xetex 
works on this latest font and mine doesn't, it's possible there's also 
something amiss with the version of xetex I have.)

    Michael Maxwell
    University of Maryland

More information about the XeTeX mailing list