[XeTeX] misplaced accents in printout only?

David J. Perry hospes.primus at verizon.net
Mon Jan 18 23:58:32 CET 2016

I don't have an exact answer, but something similar recently happened to 
me.  I have a PDF with a bunch of Old Italic characters.   It displays 
correctly on screen regardless of what computer I use.  If I print from 
my laptop downstairs to the Brother network printer in my study 
upstairs, the Old Italic characters all come out as nonsense (some 
accent shapes, a few odd letters).  If I print it upstairs on a 
different computer, but using the same network printer, all is well.  
It's a Brother multifunction machine with the latest Windows driver 
installed on both machines.  Moral: PDFs aren't as bulletproof as we think.

I assume you have already considered: are the fonts embedded in the 
PDF?  Did he enter the characters as precomposed combinations or by 
using combining marks?  First option more likely, I imagine.

This is a real shot in the dark, but here goes:
Is it possible that, at some point in the process, the precomposed 
characters were decomposed and then put back together in a way that 
affected the output?  If the font in use contains precomposed 
combinations but does not support positioning of combining marks this 
might happen. ???


On 1/18/2016 5:14 PM, Dominik Wujastyk wrote:
> A student of mine is preparing a PhD thesis with XeLaTeX.  He recently 
> sent me his​ draft as a PDF (xelatex -> dvipdfmx (20150315)).  I 
> attach a page of this, kkk.pdf, extracted from the thesis with pdftk.
> The Sanskrit text in roman script contains a number of letters that 
> have under-dots, like ṣṭḥṃ etc.  He is typing this with a 
> Unicode-aware editor, SublimeText.
> His PDF output from XeTeX displays on the screen just fine, using 
> Okular or Evince (Linux Mint 17.3 etc.).
> But when I /print/ his document on my HP LaserJet Pro 400 MFP printer, 
> the underdots have turned into overdots, and are shifted slightly 
> horizontally.  I attach a scan of the printed output, kkk-pdf-scan.pdf.
> I haven't encountered anything quite like this before, and it baffles 
> me.  I've tried outputting the PDF to PS and printing that.  Printing 
> the PDF to another PDF.  I've tried using Evince not Okular.  Always 
> the same problem.  Everything points to the printer or the printer 
> driver.  But this is not a hole-in-the-wall printer, and I'm using 
> HP's own driver.  HP knows how to interpret PostScript, surely.
> The system details for the installed printer and driver are:
> HP_LaserJet_400_MFP_M425dn
> --------------------------
> Type: Printer
> Device URI: hp:/usb/HP_LaserJet_400_MFP_M425dn?serial=CNF8H3NM1D
> PPD: /etc/cups/ppd/HP_LaserJet_400_MFP_M425dn.ppd
> PPD Description: HP LaserJet 400 MFP M425 Postscript (recommended)
> Printer Sending data to printer.Jet_400_MFP_M425dn is idle. enabled 
> since Mon 18 Jan 2016 14:27:39 MST
> Required plug-in status: Installed
> Communication status: Good
> I've run HP's diagnostics, and it is satisfied that the printer is 
> properly installed and everything's up to date.
> Can anyone shed any light on this problem?
> Dominik
> --------------------------------------------------
> Subscriptions, Archive, and List information, etc.:
>    http://tug.org/mailman/listinfo/xetex

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/xetex/attachments/20160118/f6c242be/attachment.html>

More information about the XeTeX mailing list