[XeTeX] urgent help needed

Mohammad Gharaibeh mgharaibeh at uni-bonn.de
Fri Apr 4 08:36:16 CEST 2014

Dear Ulrike,

thank you for your quick response.

You're right. I should have written a bit more.

I used MikTex and TexMaker (and still using them) on a Windows XP system.
Then I installed the new versions of MikTex ad TexMaker on a Windows 7
system and opened the old document.
Creating a PDF did not succeed properly and I got errors. The most
significant was that the entire footnote section in the PDF was missing. I
assume that some packages weren't supported any more.

Anyway, I am going to follow you suggestions and begin with a small document
and building it up more and more. Meanwhile I would really appreciate if you
could test the document that I sent to you and run the PDF creator. If
everything looks fine the problem lies in the settings of TexMaker.

With regard to the updated MikTex 2.7, I wanted to put a sentence in the
Text in red letters and tried to import a package for that (I think it was
Xecolor). After that the system was telling me I would use a source that is
more than five year old and that I should consider downloading the recent
version. I first ignored that, but had to recognize that TexMaker did not
create a PDF anymore. That is why I tried to install MikTex 2.9.

Sorry again for my stupid questions. But since I haven't worked with XeTeX
for five years, I simply don't know where to start.


-----Ursprüngliche Nachricht-----
Von: XeTeX [mailto:xetex-bounces at tug.org] Im Auftrag von Ulrike Fischer
Gesendet: Mittwoch, 2. April 2014 09:24
An: xetex at tug.org
Betreff: Re: [XeTeX] urgent help needed

Am Tue, 1 Apr 2014 09:25:22 +0200 schrieb Mohammad Gharaibeh:

> Dear all,
> hope this finds everyone well.
> Well, my problem will certainly look a bit stupid but there is a story 
> behind it I probably should start with.
> In 2007/8 my colleague and me wanted to edit an Arabic manuscript and 
> we decided to do it with XeTeX. Everything works fine so far. But when 
> in 2009 the funding ended we were force to put the project aside. Now, 
> five years later we decide to bring the project to an end and I 
> started to work with XeTeX again. Since we already finished the 
> editing process I just needed to add some corrections and everything 
> seems fine. But then, I did something very stupid. I connected the old 
> laptop at which we had installed Mik Tex and Tex Maker with the internet
and the program tried to make an update.

Which programm exactly? Miktex, Texmaker, Windows?  (Windows XP?)

> There I recognized five years won't pass without new technological 
> developments. Now my system tells me that I should switch to the 
> current version of Mik Tex and Tex Maker too, has already been developed

The support of miktex 2.7. has stopped and *if* you tried to use its update
manager or the package manager it would perhaps give such a message. But it
would not have forced you to update and normally it should still work fine.
TeXMaker could also give such a message but
again: you don't have to update if you don't want.  

> I would have continued to use the old version if it had functioned 
> normally. But obviously it doesn't work normally anymore.

I don't find this obvious. 

> For this, I downloaded and installed the Mik Tex 2.9 and tried to open 
> the old files with it. But this does not work properly either.

This is not a sensible problem description. What doesn't work? Did you get
errors? What exactly did you try?

> I probably need to change just a few settings but after five years of 
> not working with XeTeX at all I am simply overstrained with it.
Start with a small document:

Find the texworks editor (it should have been installed with miktex). Create
there a small document

hallo Bonn

Save it to a document folder as test.tex

In the dropdown menu beside the green arrow choose xelatex and then click on
the green arrow. If the compilation succeeds try it with your larger

Ulrike Fischer

Subscriptions, Archive, and List information, etc.:

More information about the XeTeX mailing list