[XeTeX] Font Location Issue?

William Voelker rekleov at gmail.com
Wed Jul 24 15:37:15 CEST 2013


I recently upgraded my Mountain Lion system to the MacTex 2013 distribution, and eliminated the older distributions I had previously installed ('10, '11, '12).

Here's my problem: while everything else I've thrown at '13 has worked just fine, it simply refuses to use one particular font. Stone Sans ITC TT is installed in /Library/Fonts (as it was before, when things worked; the .tex file I'm processing has also not been changed, and worked fine in '12), and now I receive this error:

	kpathsea:make_tex: Invalid fontname `Stone Sans ITC TT', contains ' '

	! fontspec error: "font-not-found"
	! The font "Stone Sans ITC TT" cannot be found.
	! See the fontspec documentation for further information.
	! For immediate help type H <return>.

I have updated everything with the TeXLive utility, rerun the updmap-sys utility, reinstalled the font, cleaned out the font cache (via Onyx), have tried other, randomly chosen fonts from the same directory (all of which have worked, even those with spaces in their names), and yet fontspec refuses to find the font (using, for example, this command in the header: \setromanfont[Ligatures=Common]{Stone Sans ITC TT}).

Suggestions for resolving this are appreciated! Thank you.


More information about the XeTeX mailing list