[XeTeX] bold small caps, but no regular small caps

Khaled Hosny khaledhosny at eglug.org
Fri Aug 2 18:38:31 CEST 2013

On Fri, Aug 02, 2013 at 12:40:28PM +0200, Georg Duffner wrote:
> Am 01.08.2013 13:24, schrieb Khaled Hosny:
> >On Thu, Aug 01, 2013 at 12:06:43PM +0200, Georg Duffner wrote:
> >>Hi,
> >>
> >>XeTeX’s behaviour in this case is mysterious.
> >>
> >>I tried Mike’s original tex file and got no smallcaps at all. After
> >>updating Charis to 4.114 (from 4.106) I got the same behaviour as
> >>him: no smallcaps with regular but with bold yes. When I tried again
> >>today, there are no smallcaps at all – I suppose, after the update
> >>on monday, the old version stayed in the cache and confused XeTeX’s
> >>rendering choice(?), while today the cache was rebuilt without the
> >>old files, thus XeTeX stays with graphite.
> >
> >No idea, but having suffered from mysterious Windows font installation
> >issues before (not with XeTeX), I’ve learned to delete the existing
> >font(s) before installing a new version.
> >
> I tried to reproduce the above behaviour by deleting and adding
> different versions – without success.

This explains your XDV files; it is identical to what I get here (sans
the timestamp). So I guess it was some temporary brokeness, but I’m not
convinced that this is a XeTeX bug, installing multiple versions of the
same font is strongly discouraged.

> >>And just to make sure that I understand correctly,
> >>\addfontfeature{RawFeature=+smcp} as in the second line does work as
> >>expected, because the graphite feature in this case is named "smcp"
> >>like the OT feature?
> >
> >Yes (fontspec fails because it first checks if the font supports the
> >given feature and if not it removes it from font definition, and since
> >it is looking for OpenType features it finds none when Graphite shaper
> >is used).
> Ok. The graphite tag for smallcaps in Charis has been changed to
> smcp with v4.112, before it was "1058". Shouldn’t the older versions
> show smallcaps with \addfontfeature{RawFeature=+1058}?

It should be RawFeature=1058=1; (we now support +tag as a bonus for
features that has OpenType-like tag names, but for numeric ids only
the old syntax of id=setting is supported).


More information about the XeTeX mailing list