[XeTeX] Texworks not finding .sty file

Wilfred van Rooijen wvanrooijen at yahoo.com
Thu May 3 04:25:44 CEST 2012

As mentioned by Pete, you have to update the database of filenames that TeX uses to locate files on your computer.

In most tex-distributions there are four places where stylefiles and classfiles may be located:

- In the tree of the distribution itself. For most casual users, this is the only place where tex-related files will be
- A "system-wide local tree" - this is intended to put files which are common to all users on a multi-user system, but do not belong to the tex distribution. For instance a university group may have their thesis style files in such a place. This tree is not touched if the main tex-tree is updated. 

- A "user local tree" - intended to hold files relating to an individual user
- In the "source directory"

Only the "source directory" is scanned automatically by tex. For files in all other locations, a database is maintained.In all cases, you have to specify the "basis" directory. Underneath that basis directory, you have to maintain the TeX Directory Structure (TDS) because the search engine will only search directory trees which have the correct sturcture. There are several configuration settings to instruct tex as to which directories are (recursively) added to the tex-tree. In TeXLive, the variables are $TEXMFMAIN, $TEXMFLOCAL, $TEXMFHOME, $TEXMF, and others. You can get an overview by typing "texconfig" in a terminal window.

Of course, a user may break the rules and put files elsewhere - but then you have to make sure that tex knows where your files are.


 From: Malcolm Keating <c.malcolm.keating at gmail.com>
To: xetex at tug.org 
Sent: Thursday, 3 May 2012, 4:16
Subject: [XeTeX] Texworks not finding .sty file

I am running TeXworks on my Mac OS X and trying to call:


I have made sure that utdiss2.sty is located in the directory:


However, when I compile, I get:

! LaTeX Error: File `utdiss2.sty' not found.

I have spent several hours looking online to see if I am putting the files in the wrong directory or if there is an additional step I need to perform in order to make TeXworks recognize the file. I've come up empty (I've tried putting the file in numerous places and still get the same result). I tried to run texhash using Terminal, but when I ran "sudo texhash" I got the reply "command not found."

Any suggestions? My apologies for most likely missing something obvious. I've been using XeLaTeX for only a few months now.


Subscriptions, Archive, and List information, etc.:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/xetex/attachments/20120502/b6da59a0/attachment.html>

More information about the XeTeX mailing list