[XeTeX] \emph{} exceeds TeX capacity with slides

Axel E. Retif axel.retif at mac.com
Fri Oct 15 07:26:02 CEST 2010

On  14 Oct, 2010, at 13:44, Pablo Rodríguez wrote:

> for some strange reason using both XeTeX and LuaTeX the \emph{} command contained in the sample document below exceeds TeX capacity:
> \documentclass[12pt]{slides}
> \usepackage{fontspec}
> \setsansfont{FreeSans}
> \begin{document}
> hi \emph{hello}
> \end{document}
> This only happens when fontspec is loaded with the slides as documentclass.
> I guess this might be a bug in fontspec (I use TL2010 and I updated all new packages today).
> Could anyone confirm this?

Yes, I do ---exactly the same error you posted in the TeXLive mailing list. I changed the font to DejaVuSans, as I don't have FreeSans. Also, as the log said that the 12pt option was unused, I tried with and without it.

I used \emph{ }, \textit{ } and {\itshape } and got the same error, but not with \textbf{ }, as you said in the other list (one has to read both emails to get the whole picture).



More information about the XeTeX mailing list