[XeTeX] fontspec location problems in MiKTeX

Khaled Hosny khaledhosny at eglug.org
Wed Oct 6 00:15:14 CEST 2010

On Tue, Oct 05, 2010 at 02:15:42PM -0700, Michiel Kamermans wrote:
> I tried updating to MiKTeX 2.9 beta, to see if that solved the
> problem - everything now at least resolves to the right location,
> but fontspec is exhibiting a different problem. Take the following
> UTF-8 encoded .tex file:
> \documentclass{article}
> \usepackage{fontspec}
> \setmainfont{MS Mincho}
> \begin{document}
> This is text - にほんご
> \end{document}
> This compiles without errors, but gives the following as PDF output:
> Sghr hr sdws , ➢➳々➈
> That really doesn't look like the text it should be, all the Latin
> letters (including - but not including space!) are shifted one
> alphabetical position, and the Japanese has been completely
> destroyed (に, U+306B, dec 12395, utf-bin
> {1110.0011-10.000001-10.101011}, has been turned into ➢, U+27A2, dec
> 10146, bin {1110.0010-10.011110-10.100010}). The off-by-one for
> Latin seems an honest mistake, but it also looks like it's doing
> something creative to each byte in a set of UTF8 bytes, subtracting
> 1 in a creative way... but not for the last byte, where it's
> removing 9...

Make sure you don't have to different versions of "MS Mincho" font
accessible to XeTeX (possiply in different formats) as this is known to
cause this kind of issues.


 Khaled Hosny
 Arabic localiser and member of Arabeyes.org team
 Free font developer

More information about the XeTeX mailing list