[XeTeX] Problems finding/using fonts with both xdv2pdf and xdvipdfmx

Nicholas Riley njriley at illinois.edu
Fri Oct 1 08:21:09 CEST 2010


I just started using XeTeX again after a several-year gap.  I  
installed MacTeX 2010 and am having issues with fonts not being found  
or not usable.  I'm pretty sure this all worked in earlier versions  
but I made the mistake of removing my old installation before I  
checked that it worked...

I'm having issues both with xdv2pdf and xdvipdfmx.

With xdv2pdf (which I had been using exclusively before), I can get my  
preferred text font to display but not math fonts.  In addition, on my  
10.6 machine, I don't get any bullets in lists; this is not a problem  
on my 10.5 machine.

I get this output:

(./writeup.aux) [1] [2] [3] (./writeup.aux)exception:  
SimplePSInterpreterException  reason: condition in if is not a boolean

*** font activation failed (status=0): cmsy10.pfb

*** font cmsy10 (CMSY10: file 'cmsy10.pfb') not found

*** font cmsy10 (cmsy10.pfb) not found, will substitute Helvetica glyphs
Output written on writeup.pdf (3 pages).

The only reference to error message I found was here:


but I would have thought that the built-in fonts should be handled?  I  
am using fontspec and tried with [no-math], [cm-default] (as I'd been  
using before); I also tried using \setmathrm to set the math font to  
the same as my text font, but it didn't make any difference, I guess  
because it's trying to retrieve math symbols.  I also tried installing  
the native Mac versions of the Latin Modern fonts that came with  
MacTeX but that did not help.

I don't really care *what* symbol font gets used, so if there's an  
alternative to cmsy10, that's fine too.  All I wanted in this case was  
a large centered ~ (i.e. $\sim$).

On the other hand, xdvipdfmx seems to be unable to find a font that  
xdv2pdf can:

(./writeup.aux) [1] [2] [3] (./writeup.aux)
** ERROR ** Cannot proceed without the "native" font: Goudy-Bold  
(Goudy Bold)...

Output file removed.

This is the beginning of my document, if it helps:

%!TEX TS-program = xelatexmk
\usepackage[cm-default]{fontspec} % also tried [no-math] and nothing

If I remove \setmainfont, this works and is completely formatted in  
Computer Modern with xdvipdfmx, but at that point I might as well not  
be using XeTeX.


Nicholas Riley <njriley at illinois.edu>

More information about the XeTeX mailing list