[XeTeX] Segmentation fault error in xdvipdfmx 0.7.8 with CharisSIL 4.106

George N. White III gnwiii at gmail.com
Mon Feb 1 23:00:41 CET 2010

On Mon, Feb 1, 2010 at 2:30 PM, Benct Philip Jonsson <bpj at melroch.se> wrote:
> In a bit of a hurry.  Things *are* piling up today!
> George N. White III skrev:
>> On Mon, Feb 1, 2010 at 5:16 AM, Benct Philip Jonsson <bpj at melroch.se>
>> wrote:
>>> I suddenly get a Segmentation fault error in
>>> xdvipdfmx with CharisSIL 4.106.  It's been a
>>> couple of weeks since I last used CharisSIL in
>>> XeLaTeX, but I've not knowingly changed anything
>>> in my setup since, though the Ubuntu update
>>> manager may have...  It happens with all input
>>> using this font, however minimal.  I tried to
>>> reinstall the font and to install it at another
>>> location, to no avail.  I also checked that no
>>> older versions of the font are lurking around
>>> anywhere.
>> I'm not encountering problems with my docs
>> on ubuntu-9.10 (i686).   Is your OS (uname -m)  i686?
> Yes.
>> If you are running a 64-bit OS, are you using the i386-linux
>> or the 64-bit x86_64-linux binaries?
>> Can you post a minimal input file?  What
>> happens if you modify sample2e.tex to
>> use Charis-SIL?  I called it x-sample2e.tex,
>> which has:
>> \usepackage{xltxtra}
>> \defaultfontfeatures{Mapping=tex-text}
>> \setromanfont{Charis SIL}
> Same error.
> /BP

Do you trust your hardware?   Hopefully someone with the exact same
distro will try the x-sample2e.tex test.  If they don't see the problem
then we need to consider hardware.

Grasping at straws, you could try rebuilding the font cache with
fc-cache -f.

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

More information about the XeTeX mailing list