[XeTeX] Arabic fonts and ligatures after migrating machine

Kamal Abdali k.abdali at acm.org
Thu Apr 29 20:07:31 CEST 2010

Hi Manuel,

I tried your file and it worked as expected. Attached is the resulting pdf.

I think that for default font lookup any downloaded fonts should be copied
into either /Library/Fonts or ~/Library/Fonts. FontBook "installs" fonts in
the latter directory. But "font installation" is nothing more than copying,
so manually copying the fonts is OK too.

Kamal Abdali

2010/4/29 Manuel Souto Pico <m.soutopico at gmail.com>

> Dear all,
> After migranting to a new machine and copying all files and installing
> Tex Live again, I find that when I try to typeset (in
> TexShop) some documents that I had in Arabic, ligatures stop working.
> I use Mac OS X 10.6.3.
> The font I use is Scheherazade. I copied the file
> ScheherazadeRegAAT.ttf in /System/Library/Fonts (although it doesn't
> appear in the Font Book, I don't know why).
> My minimal example is:
> %!TEX TS-program = xelatex-xdvipdfmx
> %!TEX encoding = UTF-8 Unicode
> \documentclass[a4paper]{article}
> \usepackage{polyglossia}
> \setmainlanguage{arabic}
> \setotherlanguage{galician}
> \newfontfamily\arabicfont[Scale=1.5,Script=Arabic]{Scheherazade}
> \title{السلام عليكم}
> \begin{document}
> \maketitle
> وعليكم السلام
> \end{document}
> and the log says:
> (...)
> ! Font \@tempfontb=Scheherazade/ICU at 10.0pt not loadable: Metric
> (TFM) file or installed font not found.
> and something else but I can't copy and paste. In any case, the
> document is not compiled.
> If I replace Scheherazade with Scheherazade-AAT or with other fonts
> (Times New Roman, Geeza Pro, etc.), the document is compiled but the
> ligatures don't work.
> Has anyone had this issue? Any clue about how to solve it? I probably
> need to teak some setting that I did long ago in my former computer.
> Cheers, Manuel
> --------------------------------------------------
> Subscriptions, Archive, and List information, etc.:
>  http://tug.org/mailman/listinfo/xetex
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/xetex/attachments/20100429/16aeea1a/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pico.pdf
Type: application/pdf
Size: 12572 bytes
Desc: not available
URL: <http://tug.org/pipermail/xetex/attachments/20100429/16aeea1a/attachment-0001.pdf>

More information about the XeTeX mailing list