[XeTeX] Polyglossia errors on Windows/MikTeX 2.8/TeXworks

Peter Davis pfdavis at vistaprint.com
Thu Apr 15 22:34:57 CEST 2010

I'm trying to compile the polyglossia sample file, test-polyglossia-setup.tex, but it's failing with errors like:

! Undefined control sequence.
l.82 \newXeTeXintercharclass
\xpg at normalclass %TODO


! LaTeX Error: File `loadingorder-bidi.def' not found.

Type X to quit or <RETURN> to proceed,

or enter new name. (Default extension: def)

My searches indicate that this was a known problem that was fixed sometime in December, but I've updated everything I can find to update, and I'm still seeing this.  I've tried updating using the Start->MikTeX 2.8->Maintenance (Admin)->Update (Admin) options, and supposedly everything's up to date, but I still get the errors.

Can anyone tell me what files I need to update, where to get them, where to put them, and what commands to use to regenerate formats, etc. after?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/xetex/attachments/20100415/91a86f96/attachment.html>

More information about the XeTeX mailing list