[XeTeX] XeTeX's bug: specifical filename leads to error

Norman Gray norman at astro.gla.ac.uk
Sun Sep 27 13:29:44 CEST 2009

On 2009 Sep 26, at 16:59, Peter Dyballa wrote:

> Am 26.09.2009 um 07:38 schrieb masterray:
>> I use Ubuntu 9.04 + XeTeX 3.1415926-2.2-0.999.6. When I type  
>> 'xelatex vijos\ solutions.tex' or 'xelatex vijos\ solutions.tex '  
>> or other similar filenames in Bash, XeLaTeX gives strange error  
>> message. I ensure my .tex file is correct and even though 'vijos  
>> solutions.tex' is empty, XeLaTeX gives the error message. I think  
>> this must be a filename bug of XeLaTeX.
> It was acknowledged to be a bug and is fixed in TeX Live 2009- 
> pretest (works quite reliable, needing a proof against this  
> opinion). A workaround is *not* to use bash. Tcsh does not show  
> this. Another workaround, in bash, is to create a hard-link  
> <file_name> of <name with space(s)> and running xelatex on it...

Out of curiousity, is there a pointer to this bug?

I tried to reproduce it (with the same XeTeX version) and failed, and  
I'm puzzled thinking of what sort of filename bug could conceivably be  
worked around by a change of shell.

Don't go to any trouble, anyone, but if you happen to have a URL to  

Best wishes,


Norman Gray  :  http://nxg.me.uk
Dept Physics and Astronomy, University of Leicester, UK

More information about the XeTeX mailing list