[XeTeX] Strange problem with 0.996 and 0.9995 xetex and File Names.

Fr. Michael Gilmary FrMichaelGilmary at MaroniteMonks.org
Sat Sep 5 14:49:59 CEST 2009

Peter Dyballa wrote:

> Am 05.09.2009 um 13:06 schrieb Apostolos Syropoulos:
>> $ xelatex "test II"
>> Segmentation Fault (core dumped)
>> $ xelatex test\ II.tex
>> This is XeTeX, Version 3.1415926-2.2-0.9995.0 (TeX Live 2009)
>> entering extended mode
>> (./test II.tex
>> LaTeX2e <2005/12/01>
> This is *really* fascinating! I changed the shell I was working in 
> from tcsh to bash (2.05b.0(1)-release (powerpc-apple-darwin8.0)) � and 
> for me xelatex crashes whenever I pass "file name.tex" (with 
> extension) to the programme... It runs OK when I don't give the 
> extension.
> I wouldn't trust born again folks and things!

Well, here we can produce output with no errors with bash (GNU bash, 
version 2.05b.0(1)-release (powerpc-apple-darwin8.0)) on Mac OS 10.4.11.

I tried TeXShop and terminal, bash, ksh, tcsh and everything ran fine, 
xelatex test2.tex
xelatex test2

xelatex test\ 2.tex
xelatex test\ 2

xelatex testII.tex
xelatex testII

xelatex test\ II.tex
xelatex test\ II

Curiously, though, when I ran zsh, it processed only the files named 
with the roman numeral, but said it couldn't find the file: test\ 2 --- 
with or without the .tex extension. But I'm no expert in shells.

United in adoration of Jesus, 

fr. michael gilmary, mma

Most Holy Trinity Monastery
67 Dugway Road
Petersham, MA 01366-9725

More information about the XeTeX mailing list