[XeTeX] Font not found error

Dr J.D. Billett jdb43 at cam.ac.uk
Mon Jul 20 19:28:04 CEST 2009

A long time ago now (Jul 2), Jesse Billett wrote:
> With the patient off-list assistance of Peter Baker, I've been trying
> to typeset a document with xelatex using the font TeX Gyre Termes.  I
> was having trouble getting the ffi ligature to appear, which by
> consensus of the mailing list was to do with a problem in the font's
> GSUB table.  With some outside help, I've got a version of the font
> with the GSUB table repaired in FontForge.  But now I can't get
> xelatex to find it.  Instead, I get the following error message:
> ! Font \zf at basefont="TeX Gyre Termes" at 10.0pt not loadable: Metric
> (TFM) file
>   or installed font not found.
> \zf at fontspec ...ntname \zf at suffix " at \f at size pt
>                                                    \unless \ifzf at icu
> \zf at set@...
> l.3 ...x-text,Ligatures={Common}]{TeX Gyre Termes}
> This appears when I run xelatex on the following minimal example file:
> \documentclass[11pt]{memoir}
> \usepackage{fontspec}
> \setmainfont[Mapping=tex-text,Ligatures={Common}]{TeX Gyre Termes}
> \begin{document}
> \noindent fi fl ff ffi ffl\\
> \textit{fi fl ff ffi ffl}
> \end{document}
> I tried to delete this altered version and re-install the old, flawed
> fonts I originally downloaded from the GUST e-foundry, but the same
> error message appeared.  I have tried deleting my fonts cache with
> OnyX (I'm running OS X 10.4.11), but this doesn't help.  TeX Gyre
> Termes is, however, available in other applications (MS Word,  
> TextEdit).
> Any thoughts on what's going wrong here?  I can't figure out why I
> can't get ANY version of TeX Gyre Termes to be recognized by xelatex.
> Jesse Billett

Among the several very helpful respondents, Fr. Michael Gilmary wrote:

> I have the same OS as you do (10.4.11) and I ran the file first  
> with the
> TL2008 version of TeX Gyre Termes and there was no ffi/ffl ligature.
> Then I ran Khaled Hosny's python script via X11 ... and with the
> corrected version of the font, I get the same error message as you do
> with your example.
> I think Mac OS 10.4 has some bug that doesn't work well with FontForge
> for altering fonts.
> Does anyone with Leopard have this problem with TeX Gyre Termes ---
> after running Khaled's script?

I have now achieved at least a temporary fix to this problem.  I  
pasted Peter Baker's repaired TeX Gyre Termes fonts into the  
directory where my input file lives; I ran texhash; and I changed the  
fontspec call in the preamble to the following:


This allows for all the other fonts (italic, bold, etc.) to be found  
too.  I guess this will have to do until I upgrade to 10.5!

Thanks for your help, everyone.


More information about the XeTeX mailing list