[XeTeX] Font not found error

Dr J.D. Billett jdb43 at cam.ac.uk
Thu Jul 2 13:28:38 CEST 2009

With the patient off-list assistance of Peter Baker, I've been trying  
to typeset a document with xelatex using the font TeX Gyre Termes.  I  
was having trouble getting the ffi ligature to appear, which by  
consensus of the mailing list was to do with a problem in the font's  
GSUB table.  With some outside help, I've got a version of the font  
with the GSUB table repaired in FontForge.  But now I can't get  
xelatex to find it.  Instead, I get the following error message:

! Font \zf at basefont="TeX Gyre Termes" at 10.0pt not loadable: Metric  
(TFM) file
  or installed font not found.
\zf at fontspec ...ntname \zf at suffix " at \f at size pt
                                                   \unless \ifzf at icu  
\zf at set@...
l.3 ...x-text,Ligatures={Common}]{TeX Gyre Termes}

This appears when I run xelatex on the following minimal example file:

\setmainfont[Mapping=tex-text,Ligatures={Common}]{TeX Gyre Termes}


\noindent fi fl ff ffi ffl\\
\textit{fi fl ff ffi ffl}


I tried to delete this altered version and re-install the old, flawed  
fonts I originally downloaded from the GUST e-foundry, but the same  
error message appeared.  I have tried deleting my fonts cache with  
OnyX (I'm running OS X 10.4.11), but this doesn't help.  TeX Gyre  
Termes is, however, available in other applications (MS Word, TextEdit).

Any thoughts on what's going wrong here?  I can't figure out why I  
can't get ANY version of TeX Gyre Termes to be recognized by xelatex.

Jesse Billett

More information about the XeTeX mailing list