[XeTeX] Problem (File does not exist) with Lyx 1.6.2 and XeTex (under TexLive 2009)

Peter Dyballa Peter_Dyballa at Web.DE
Mon Aug 24 09:57:30 CEST 2009

Am 24.08.2009 um 08:21 schrieb Clemente Beghi:

> If I run a tex file with xetex with the command line I get:
> This is XeTeX, Version 3.1415926-2.2-0.9995.0 (TeX Live 2009)
> restricted \write18 enabled.
> ---! /home/arjuna/.texlive2009/texmf-var/web2c/xetex/xelatex.fmt  
> doesn't
> match xetex.pool
> (Fatal format file error; I'm stymied)

This is easily explained: you have at least one private FMT file for  
TeX Live 2009. And you might have also set some TeX related  
environment variables (try "env | egrep -i 'mf|tex'" on some command  
line) which interfere. Another option is that LyX has it's own idea.

IMO creating FMT and other files in ~/.texlive<year> is a mistake.  
Usually the system's files are good enough. And (automatically)  
maintained! So I recommend to check the contents of the  
~/.texlive2009 branch and if you think you can't remove it at once,  
rename it to ~/.texlive2009-scrap or such. Problem hopefully solved.

Then learn that the system's distribution is maintained by 'sudo  
fmtutil-sys' or 'sudo updmap-sys' or 'sudo texconfig-sys'  (maybe you  
need to use 'sudo -H' instead of the simple 'sudo') and maybe also by  
'sudo tlmgr' to update your distribution (TL'09 is not yet released,  
you have some snapshot, which can have updates every day). Tlmgr, TeX  
Live manager, updates automatically FMT and MAP files.



How many Microsoft engineers does it take to screw in a light-bulb?
They just redefine "dark" as the new standard.

More information about the XeTeX mailing list