[XeTeX] pstricks pst-math pst-plot and xelatex

Barry MacKichan barry.mackichan at mackichan.com
Tue Oct 28 04:33:35 CET 2008

Poking around, I found that MikTeX doesn't use the Ghostscript that I
thought it did. In MikTeX's bin directory is mgs.exe, which is
Ghostscript 8.60. It was unable to find files such as gs_init.ps (I
think this is the cause of the failure messages). The file is in "miktex
2.7/ghostscript/base" but is not being found. Setting GS_LIB in the
environment made no difference.

I uninstalled and reinstalled MikTeX, and there was no change.

I switched to TeXLive 2008, and there are no error messages, but now the
pdf file that gets produced has the axis lines, but still no blue line.
As I recall, this means the behavior I am getting is identical to what
Martin Scholz got.

The PDF and the log file are attached.


Barry MacKichan wrote:
> I had 8.54. I upgraded to 8.63 (8.61 wasn't still available), and
> upgraded my path, and I get the same result.
> In the 8.54 bin directory, there was a ps.exe file. There is none in
> 8.63. I assume this means that xelatex is looking for gswin32.exe or
> gswin32c.exe.
> --Barry
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.pdf
Type: application/pdf
Size: 3587 bytes
Desc: not available
Url : http://tug.org/pipermail/xetex/attachments/20081027/1fa8cb34/attachment.pdf 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: test.log
Url: http://tug.org/pipermail/xetex/attachments/20081027/1fa8cb34/attachment.pl 

More information about the XeTeX mailing list