[XeTeX] graphics inclusion

Jonathan Kew jonathan_kew at sil.org
Sun Dec 9 20:54:30 CET 2007

On 9 Dec 2007, at 11:45 am, Guy wrote:

> Yes, the terminal has this error when I run xelatex on that file:
>> ! Unable to load picture or PDF file '``srikanthacrop.pdf'.
>> <to be read again>
>>                    \unhbox
> and, despite the log file, there is just a blank space where my
> included graphic should be in the output.

I'm baffled by this, and wonder if you're accidentally mixing  
different versions of your file, log file, etc. I don't see any way  
that xelatex can stop with an "! Unable to load..." error like this  
on the terminal, yet not show any trace of it in the .log.

The quote marks shown on your error message (above) make it look like  
at some point there might have been quote marks within your  
\includegraphics command, and those were confusing graphicx or  
xetex.def; but the .log you sent shows a different (apparently  
successful) story.

Could it be that you've had an old version of the PDF open in  
whatever viewer you're using, and it hasn't reloaded the file after  
different experiments with the input; this could have misled you into  
thinking things failed when in fact they ran successfully?


> Pdflatex will produce the
> proper graphic-included output, but not latex (which produces an empty
> box) or xelatex (blank space).  It seems that I'm missing some basic
> element or configuration in latex and xelatex, no?  Does pdflatex come
> bundled with anything that those two don't?  Or are there any basic
> dependencies for xe/latex that I might have overlooked?  Thanks again.
> guy
> On Dec 9, 2007 1:53 AM, Jonathan Kew <jonathan_kew at sil.org> wrote:
>> On 8 Dec 2007, at 7:34 pm, Guy wrote:
>>> Hi and thanks again for the assistance.  I tried your suggestions,
>>> Jonathan, re trying another pdf and specifying [xetex] as an option
>>> for graphicx, but got the same result.  I'll check on the ubuntu
>>> forums to see whether anyone else has had similar problems.  Here's
>>> the .log for my test file:
>> According to this log....
>>> This is XeTeXk, Version 3.141592-2.2-0.996 (Web2C 7.5.6)
>>> (format=xelatex 2007.12.1)  8 DEC 2007 20:26
>>> entering extended mode
>>>  %&-line parsing enabled.
>>> **testpractice.tex
>>> (./testpractice.tex
>>> <....snip....>
>>> File: srikanthacrop.pdf Graphic file (type QTm)
>>> <use  "srikanthacrop.pdf" > [1
>>> ] (./testpractice.aux) )
>>> Here is how much of TeX's memory you used:
>>>  4794 strings out of 95792
>>>  78036 string characters out of 1190515
>>>  146352 words of memory out of 1500000
>>>  7892 multiletter control sequences out of 10000+50000
>>>  3680 words of font info for 19 fonts, out of 1200000 for 2000
>>>  28 hyphenation exceptions out of 8191
>>>  28i,6n,43p,340b,255s stack positions out of 5000i,500n,6000p,
>>> 200000b,5000s
>>> Output written on testpractice.pdf (1 page).
>> ....it looks like the job ran with no error message; it seems to have
>> loaded your pdf file fine. I don't see what the problem is here. Are
>> you saying that you get an error message on the terminal even though
>> the log file shows a job that ran to completion? Or is the included
>> pdf missing from the output even though xelatex appeared to load  
>> it OK?
>> JK
>> _______________________________________________
>> XeTeX mailing list
>> postmaster at tug.org
>> http://tug.org/mailman/listinfo/xetex
> _______________________________________________
> XeTeX mailing list
> postmaster at tug.org
> http://tug.org/mailman/listinfo/xetex

More information about the XeTeX mailing list