[XeTeX] buggy hyphenation in XeTeX?

Bruno Voisin bvoisin at mac.com
Sat Apr 14 19:58:20 CEST 2007

Le 14 avr. 07 à 14:34, Pablo Rodríguez a écrit :

> Jonathan Kew wrote:
>> Running your example with my current development version
>> (post-0.996), I get hyphenation of "co-mo".
> Thanks for your answer, Jonathan. Where can I get your current
> development version?

 From the SVN repository. You can get a snapshot of the latest  
sources at <http://scripts.sil.org/svn-view/xetex/TRUNK/>, by using  
the "Download tarball" link at the bottom, or using directly the URL  

Afterwards you'll need to compile the sources yourself, following the  
instructions at <http://scripts.sil.org/cms/scripts/page.php? 
site_id=nrsi&item_id=xetex_linux#96c5d158> (they apply to both Linux  
and Mac OS X).

In case you're on the Mac, I remember Jonathan said while he was  
working on integration of XeTeX in TeXLive that at some point the  
modifications resulted in a non-working script install-xetex (the  
script which, after building xetex with build-xetex, put the various  
created files at the appropriate places and then configures what  
needs to be configured). I don't know whether the problem is still  
present, or whether it has since been solved.

Same applies to xdvipdfmx, where you can get the latest sources from  
<http://scripts.sil.org/svn-view/xdvipdfmx/TRUNK/> or directly  

Don't neglect also the advice on the "XeTeX on Linux" page:  
"Additional configure options or environment settings may be needed  
if some of the required libraries are not found automatically."

Last time I tried compilation myself (at the end of November last  
year), things went as follows (after
downloading the source tarballs on my Desktop, and putting them in  
Desktop/xetex and Desktop/xdvipdfmx respectively):

- For XeTeX:

$ cd Desktop/xetex/TRUNK
$ sh build-xetex
$ sudo sh install-xetex

- For xdvipdfmx:

$ cd Desktop/xdvipdfmx/TRUNK
$ sh configure --with-kpathsea=/usr/local/gwTeX
$ make
$ sudo make install

The options for "configure" must all go on the same line in Terminal.

Wait: thinking a bit more, it seems xdvipdfmx needs the kpathsea  
libraries during compilation. These are not provided in MacTeX/ 
TeXLive-2007, but they are in gwTeX (in /usr/local/gwTeX/{include/ 
kpathsea,lib}/). Hence you'll need to install gwTeX if you wish to  
compile xdvipdfmx, and use the above compilation options. The same  
restriction doesn't apply to xetex.

And of course you also need to have Xcode installed, in order to be  
able to perform a compilation.

Hope this helps,

Bruno Voisin

More information about the XeTeX mailing list