[XeTeX] MacTex install - no math symbols

Bruno Voisin bvoisin at mac.com
Fri Apr 13 15:59:56 CEST 2007

Le 13 avr. 07 à 11:12, baptiste Auguié a écrit :

> I've tried locating these two files, psfonts.map and texmf.cnf and
> they do exist, but I believe there is some conflict with my previous
> Fink install. I've tried to remove it partially, but there is still
> some references to files that were in /sw/share, ... (e.g., locate
> texmf.cnf returns /sw/share/texmf/web2c/texmf.cnf while I deleted
> this texmf folder tree).
>> kpsewhich psfonts.map returns /Users/baptiste/.texlive2007/texmf-
>> var/fonts/map/dvips/updmap/psfonts.map
> and
>>  kpsewhich texmf.cnf  gives /usr/local/texlive/2007/texmf/web2c/
>> texmf.cnf
> I've tried updating things with sudo texhash, and sudo updmap, but I
> still fails. The resulting pdf contains all the text in the desired
> font, but everything in math mode is just unreadable (figures
> superimposed on each other, ...).

Note that kpsewhich returns for you:


whereas it should return for a standard MacTeX/TeXLive-2007 install:


This I think signals you've been hit, like many others on the Mac, by  
the foo vs. foo-sys debacle that followed the incompatible syntax  
change introduced in teTeX 3 when utilities such as updmap and  
fmtutil were split in two versions, such as updmap and updmap-sys,  
and fmtutil and fmtutil-sys, intended for per-user and system-wide  
setups respectively.

As a consequence, by running "sudo updmap" you may have ended up  
creating root-owned files inside your home directory, and these files  
cannot be read when running tex and friends as a normal user. The  
exact explanation of why things go wrong may be a bit different (I'm  
no specialist on these matters), but a symptom of such a faulty setup  
is generally on a gwTeX install to have files:


which shouldn't exist (the various distros of TeX for the Mac assume  
a system-wide setup the default, with per-user setups the exception  
to be chosen only by expert users who really know what they're doing,  
and normally upon installation these distros make updmap equivalent  
to updmap-sys and fmtutil equivalent to fmtutil-sys).

I suspect that on a MacTeX install the corresponding symptom would be  
to have files:


and that this is precisely your situation. If that's indeed the  
correct explanation, then you should erase these files then run  
mktexlsr, updmap-sys and fmtutil-sys to re-configure your setup  

Maybe the simplest way to proceed is erase the whole ~/.texlive2007  
directory then redo the configuration:

sudo mktexlsr
sudo -H updmap-sys
sudo -H fmtutil-sys --all

Hope this works,

Bruno Voisin

More information about the XeTeX mailing list