[XeTeX] Accessing Latin Modern OTF fonts for use within XeLaTeX

R (Chandra) Chandrasekhar chandra at ee.uwa.edu.au
Fri Nov 3 17:02:51 CET 2006

Dear Folks,

I am trying to access the Latin Modern Fonts OTF fonts from within XeLaTeX just 
as I would any other TTF or OTF font on my system.

I am on Kubuntu Dapper and tried to import the fonts from the lm.zip archive 
from TUG using the KDE Font Manager in the Control Centre.  The difficulty is 
that when a font is added from, say, a file like "lmroman10-dunhilloblique.otf" 
the resulting name is not "Latin Modern Dunhill Oblique 10" (as I believe it 
should be) but rather "Latin Modern Roman, Oblique", which is not unique.

I do not know why this is so, but I would like to fix it by a workaround, if 
possible.  FYI,  a symlink like

ln -s lmroman10-dunhilloblique.otf "Latin Modern Dunhill Oblique 10.otf"

does not work, implying that the full font name is being read from the .otf file 
itself and there may be a parsing error during file import.  But the KDE Font 
Manager has worked well when other TTF or OTF fonts were added.

So, how do I access the Latin Modern OTF fonts like other OTF fonts on my system 
for use within XeLaTeX?


03 Nov 06

More information about the XeTeX mailing list