[XeTeX] Differing font name handling betwixt Mac OS X and W32 (and Linux?) XeTeX

William Adams will.adams at frycomm.com
Mon Jun 19 13:51:55 CEST 2006

Just wanted to chime in here that I tried the new version over the  
weekend and had the following observations / comments:

  - performance seems a lot slower now --- right after reading  
fontspec.cfg there's no change in the log information on-screen for a  
couple of minutes at least (this on a Pentium 233, so probably not a  
big deal, but it might be worth looking into if considering  

  - Garamond Premier Pro works w/o spaces \fontspec{GaramondPremrPro}

  - other fonts need the space though

  - where should one look to determine what name should be used (to  
load a font)? I used the TTF properties extension from Microsoft.com  
(Properties | Names (tab) | Font Family Name) and that works for most  
fonts (but not Garamond Premr Pro --- now it works based on the Font  

  - what encoding is the namelist.tex file supposed to be in? Is  
there any easy way to typeset it nicely? It seems to've only  
processed the files in the first directory (winnt\fonts) and left  
behind a .fonts.cache-2 file

  - I couldn't get Aldus LT Std to work using Fontspec (again,  
haven't been trying w/ Plain) --- anyone else tried this?

In case anyone is curious, here's a list of fontspec commands which  
did work for me in W32tex (and one which doesn't):

%\setromanfont{Aachen Std Bold}
%\setromanfont{Adobe Garamond Pro}
%\setromanfont{Adobe Caslon Pro}
%\setromanfont{Albertus MT Std}
%\setromanfont{AldusLTStd-Roman} --- didn't work
%\setromanfont{Alexa Std}
%\setromanfont{Americana Std}

These work for at least \emph and textbf (where there's an italic or  
a bold, though if memory serves, it was the extra-bold variant of  
Americana which was chosen.

I've just checked and they all seem to work in Mac OS X as well.

In addition:

\setromanfont{Palatino Linotype}

worked in w32tex as well (but I don't have it on my Mac OS X box)

Testing Aldus on my G5, the following were unsuccessful:

\setromanfont{Aldus LT Std}

but this did work on my G5 (and allowed the \emph italics command to  
work as well:


but I've double-checked and it didn't work in W32xetex on my pen slate.

William Adams
senior graphic designer
Fry Communications

This email message and any files transmitted with it contain information
which is confidential and intended only for the addressee(s). If you are
not the intended recipient(s), any usage,  dissemination, disclosure, or
action taken in  reliance on it is prohibited.  The reliability of  this
method of communication cannot be guaranteed.  Email can be intercepted,
corrupted, delayed, incompletely transmitted, virus-laden,  or otherwise
affected during transmission. Reasonable steps have been taken to reduce
the risk of viruses, but we cannot accept liability for damage sustained
as a result of this message. If you have received this message in error,
please immediately delete it and all copies of it and notify the sender.

More information about the XeTeX mailing list