[XeTeX] Compiling/Installing XeTeX

Joshua Grauman jnfo at grauman.com
Fri Aug 4 09:10:27 CEST 2006

Well, I finally got a working XeTeX!

Unfortunately, my first attempt at a document didn't come out as 
spectacularly as I would hope. Here it is, it is Genesis 1 from the sword 
project (free), using the Ezra SIL font (also free).

I think the way that the vowel points are rendered is a bug. They don't 
match up with where they are supposed to be. They're close, but noticably 
off. Can anyone tell me if they can render the document correctly (maybe 
just Linux support is behind?). Or is there something I'm missing. Thanks.


> Well, I tried uninstalling my current teTeX install (from Slackware 10.2)
> and installing fresh (from source) and I get the same error. Now I'm
> really stuck. Any ideas?
> Josh
>> So it looks like XeTeX will do everything I want, so I'm trying to install
>> it. I was able to install xdvipdfmx no problem. Trying to install XeTeX on
>> my Slackware 10.2 system I was able to get across a few problems, but not
>> all. I had to install web2c to get libkpathsea installed. After copying
>> fontconfig.h to a different directory, I got libkpathsea compiled and
>> installed (although web2c itself didn't finish compiling). Going back to
>> compile XeTeX, I got quite far, but finally it failed with (I did have the
>> teTeX 3.0 package from Slackware 10.2 installed if this makes any
>> difference):
>> c++ -I../../libs/icu-xetex/common/unicode -I../../libs/icu-xetex/common
>> -I../../../libs/icu-xetex/common/unicode -I../../../libs/icu-xetex/common
>> -I../../../libs/icu-xetex/layout/unicode -I../../../libs/icu-xetex/layout
>> -I../../../libs/icu-xetex -DLE_USE_CMEMORY -I. -I..
>> -I/usr/include/freetype2/  -DHAVE_CONFIG_H -DXETEX_OTHER -c
>> ../../../texk/web2c/xetexdir/XeTeXFontMgr_Linux.cpp -o
>> XeTeXFontMgr_Linux.o
>> ../../../texk/web2c/xetexdir/XeTeXFontMgr_Linux.cpp: In member function `
>>    virtual XeTeXFontMgr::NameCollection*
>>    XeTeXFontMgr_Linux::readNames(FcPattern*)':
>> ../../../texk/web2c/xetexdir/XeTeXFontMgr_Linux.cpp:26: error:
>>    undeclared (first use this function)
>> ../../../texk/web2c/xetexdir/XeTeXFontMgr_Linux.cpp:26: error: (Each
>> undeclared
>>    identifier is reported only once for each function it appears in.)
>> make: *** [XeTeXFontMgr_Linux.o] Error 1
>> ls: Work/texk/web2c/xetex: No such file or directory
>> And I'm stuck... Any ideas? Any live CDs with XeTeX included?
>> Josh
>> _______________________________________________
>> XeTeX mailing list
>> postmaster at tug.org
>> http://tug.org/mailman/listinfo/xetex
> _______________________________________________
> XeTeX mailing list
> postmaster at tug.org
> http://tug.org/mailman/listinfo/xetex
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Hebrew.tex
Type: application/x-tex
Size: 7573 bytes
Url : http://tug.org/pipermail/xetex/attachments/20060804/35cea1c7/attachment-0001.tex 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Hebrew.pdf
Type: application/pdf
Size: 16866 bytes
Url : http://tug.org/pipermail/xetex/attachments/20060804/35cea1c7/attachment-0001.pdf 

More information about the XeTeX mailing list