[XeTeX] Segmentation fault

Bruno Voisin bvoisin at mac.com
Mon Jul 25 19:01:25 CEST 2005

Le 25 juil. 05 à 18:07, Malcolm Ross a écrit :

> As the TeXShop console transcript below shows, when I run XeTeX, I  
> get the error message 'segmentation fault'. This occurs whichever  
> file I run XeTeX on. There is a pause, always at the same point,  
> then the error message appears and nothing further happens. This  
> didn't happen yesterday, nor ever before, and I cannot think of  
> anything I have done which would have occassioned this behaviour. I  
> have reinstalled XeTeX with i-Installer -- to no avail. This does  
> not happen with PDFTeX.
> A Google search tells me that a segmentation error is a Unix error  
> that 'occurs when a program attempts to access a memory location  
> that it is not allowed to access'. I understand the words  
> superficially, but they don't help me. However, my copy of  
> Microsoft Word 2004 has refused to work since yesterday (quits  
> immediately after starting up), and I am wondering if the two  
> events are connected.

At the instant the segmentation fault occurs, or Word fails to start  
up, is there any special output written to log files such as:


The easiest way to access these files is through /Applications/ 
Utilities/Console.app, clicking on the Logs button in the toolbar and  
picking up the file name in the list that appears on the left.

Bruno Voisin

More information about the XeTeX mailing list