[XeTeX] MathTime fonts

Paul Edney edney at northwestern.edu
Sat Sep 4 19:07:11 CEST 2004

Hello everyone,

As many before me, I am moving from Textures to TeXshop.  I had a few 
documents that required Textures' system font loading ability, so 
XeTeX is a godsend.

First things first: the configuration I'm using, in the order it was 
   teTex 2.0.2-36, installed by fink
   TeX, from Gerben Wierda's TUG mirror, installer by i-installed
   TeX Support: Super-CM, from Gerben Wierda's TUG mirror, installed 
by i-installer
   XeTeX 0.85, from Jonathan Kew's i-directory, installed by i-installer
   TeXshop 1.35b

The only changes were those described in the next paragraph, as well 
as adding a mathtime directory inside the otf/bluesky directory. I 
then added the mathtime pfb fonts that were converted to otf to that 
directory.  A copy of the pfb fonts is still in their original 

I got Mathtime working under LaTeX with TeXshop 1.35b after following 
the excellent instructions posted at
by Bruno, Dave, and Themis.  Thanks, guys, you saved me a major headache!

Now for XeTeX: I got everything running (i.e., finds and load system 
fonts just fine, works like a charm with euler), except for MathTime 
and CM.  I get the same blank screen with a few lines and +, -, (, 
and ) symbols.  I read the XeTeX FAQ about CM, generated .otf files 
from the .pfb, checked the texmf.cnf file for
OTFFONTS = .;$TEXMF/fonts/otf//

(It actually reads
OTFFONTS = .;$TEXMF/fonts/otf/{xetex,}//
but I doubt that is the problem.)

Then I ran
xetex -no-pdf testfile.tex

and got

This is XeTeXk, Version 3.14159-2.1-0.85 (Web2C 7.5.2)
  %&-line parsing enabled.
entering extended mode
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, british, french, german, n
german, spanish, nohyphenation, loaded.
Document Class: article 2001/04/21 v1.4e Standard LaTeX document class
For additional information on amsmath, use the `?' option.
(/usr/local/teTeX/share/texmf.tetex/tex/latex/psnfss/ts1ptm.fd) [1]
(./testfile.aux) )
Output written on testfile.xdv (1 page, 2144 bytes).
Transcript written on testfile.log.

No font errors here, so I carried on with
xdv2pdf -v myfile.xdv

and get


Activated, but I still get a blank output (aside from the few lines). 
Actually, even the regular times font doesn't show up.

I also tried the -d -1 options for xdv2pdf, but I am clueless as to 
how to interpret this.  There are a lot of 'NIL', though...

What really puzzles me is that in TeXshop, LaTeX handles mathtime 
like a charm, whereas XeTeX doesn't.  Don't they read from the same 
texmf.local tree?

I must be missing the obvious here. Can anyone please help, or 
provide a reference to RTFM?



More information about the XeTeX mailing list