[XeTeX] OS X fonts.

Bruno Voisin bvoisin at mac.com
Fri Jul 23 11:48:16 CEST 2004

Le 23 juil. 04, à 02:33, Alain Schremmer a écrit :

>> - Did you modify the default language selection of the TeX i-Package 
>> (see next answer below), to include languages for which the 
>> hyphenation pattern files (in 
>> /Library/teTeX/share/texmf.tetex/tex/generic/hyphen/) include 
>> non-UTF-8 characters?
> As far as I can remember, if this is what you mean, when I installed 
> TeXshop etc, I chose English, French, Italian and Spanish. I never 
> changed anything after that.
> I looked at  /Library/teTeX/share/texmf.tetex/tex/generic/hyphen and 
> here is what I found:
> [...]
> If what you mean is whether I changed the encoding in 
> TeXshop/Preferences/Document, I tried with MacOSRoman, then changed 
> and tried with UTF-8 Unicode, then changed back to MacOSRoman. Each 
> time, I closed and reopened XeTeX Notes and tried to typeset.

All this did not make any difference (did not modify the files that you 
opened). Changing the default encoding in TeXShop only affects new 
content, that will be written with TeXShop, it does not affect existing 
content, that is simply visualized with TeXShop. For this (encoding 
conversion), you need a tool such as Cyclone 

However, no such conversion is required in your case, as the problem is 

> - Just to be sure, is XeTeX really installed on your system (did you 
> install the i-Package using i-Installer, or the .pkg file using 
> Apple's Installer), and TeXShop configured to use it (in the Composer 
> menu, Personal Script and LaTeX both checked)? In case it is, the 
> first line of your TeXShop run in the console window should be:
>> 	This is XeTeXk, Version 3.14159-2.1-0.84 (Web2C 7.5.2)
> Here is the full console message:
> This is XeTeXk, Version 3.14159-2.1-0.84 (Web2C 7.5.2)
>  %&-line parsing enabled.
> kpathsea: Running mktexfmt XeLaTeX.xfmt
> fmtutil: no info for format `XeLaTeX'.
> I can't find the format file `XeLaTeX.xfmt'!

I am beginning to suspect that in TeXShop's Misc prefs, as personal 
scripts you specified "TeX" (without the quotes) instead of "tex" (all 
lowercase) and "XeLaTeX" instead of "xelatex" (all lowercase too). This 
makes a difference, as such command-line utilities operate at the Unix 
level inside the guts of OS X:

- The Finder does its best to hide this Unix inheritage and make file 
names behave as they did in previous Mac OS versions. For example, at 
the Finder level, case is insiginificant ("a" and "A" are the same) and 
all characters but ":" can be used in files names (in Unix "/" couldn't 
be used, as well as many others).

- At the Unix level inside OS X, case is significant ("a" and "A" are 
different), "/" cannot be used in file names (since it is the directory 
separator), etc.

So, in short, make sure that your Personal Script settings in TeXShop 
look like this:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Image 1.pdf
Type: application/pdf
Size: 11751 bytes
Desc: not available
Url : http://tug.org/pipermail/xetex/attachments/20040723/bfa3fed3/Image1-0001.pdf
-------------- next part --------------

Bruno Voisin

More information about the XeTeX mailing list