[XeTeX] Euler Script: Fixed!

Chris Menzel cmenzel at tamu.edu
Sun Dec 5 20:48:42 CET 2004

On Sun, Dec 05, 2004 at 06:39:36PM +0000, Jonathan Kew wrote:
> On 5 Dec 2004, at 1:17 pm, Chris Menzel wrote:
> >when I run xelatex I am getting the error
> >
> >  psfonts.map not found; texmf.cnf may be broken
> >
> >psfonts does in fact live in
> >/usr/local/teTeX/share/texmf.local/fonts/map/dvips/updmap/ as a symlink
> >to psfonts_t1.map in the same dir.
> xdv2pdf relies on "borrowing" dvips's configuration file to help it 
> identify font files associated with .tfm-based fonts, and use the 
> proper encodings. But apparently it isn't finding it on your system.
> In Terminal, try
> 	kpsewhich -format "dvips config" psfonts.map
> and see if it is found.... that should be equivalent (I think) to what 
> xdv2pdf does internally to locate the file.

It is immediately found by kpsewhich.

> My guess is that your texmf.cnf is lacking an entry that is needed to 
> find this file (perhaps it points to where the Fink teTeX used to be?). 

No, but I do see now that there are two texmf.cnf files -- one in
/usr/local/teTeX and one /usr/local/teTeX/share/texmf/web2c.  (There is
also /usr/local/teTeX/texmf.cnf.20041118180206.)  It appears that the
latter (the one in .../web2c) is the one being consulted, but that the
former has the right font path info.  The latter is also odd in that it
defines TEXMFLOCAL as $SELFAUTOPARENT/share/texmf-local instead of
$SELFAUTOPARENT/share/texmf.local.  I've tried pointing TEXFONTMAPS
in the web2c version right at the correct dir, but it doesn't same to
matter (for what I'm sure are to some eyes obvious reasons).

Chris Menzel

More information about the XeTeX mailing list